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Chapter 1

Getting started

This chapter helps you install and run MuseScore for the first time. The chapter will also show you

how to create a new score.

Installation

Windows
You will find the Windows installer on the Download page of the MuseScore website. Click on

the link to start the download. Your Internet browser will confirm that you want to download this

file. Click "Save File".

When the download finishes double click on the file to start the installation. Windows may open a

security window and ask you to confirm before running the software. Click "Run" to continue.

The installer recommends that you close all other applications before continuing. After you close

the other applications click "Next" to continue.

The setup wizard displays the terms of the free software license which you may review. Click "I

Agree" to continue.

Next it confirms the location for installing MuseScore. If you are installing a newer version of

MuseScore but still want to keep the old version on your computer then you should change the

http://www.musescore.org/en/download
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folder. Otherwise click "Next" to continue.

Next it confirms the name for the MuseScore folder that appears in the Windows Start menu list of

programs. Click "Install" to continue.

Give the setup wizard a few minutes to install the necessary files and configurations. When it is

done click "Finish" to exit the installer. If you wish, you may now delete the installer file you

downloaded.

Start MuseScore
To start MuseScore choose Start → All Programs → MuseScore 0.9 → MuseScore.

After several seconds MuseScore will open up to the demo score. Feel free to experiment with the

demo score and get the feel of the program. Next you may want to create your own score.

Create new score

From the main menu choose Score → New. This opens the new score wizard.
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Title, composer and other information

Enter the title, composer, or any other information as shown above. Notice the two options at the

bottom:

• Create new score from template

• Create new score from scratch

The first option offers a list of ready-made scores in the next screen. The second option gives you

the full choice of instruments in the next screen. Templates are discussed in more detail below, but

for now choose "Create new score from scratch."

Click "Next" to continue.

Instruments and voice parts

The instrument window is divided into two columns. The first column lists instruments or voice

parts to choose from. The second column is initially empty but will soon contain a list of the

instruments for your new score.

The instrument list in the first column is categorized into instrument families. Double click a

category to show the full list of instruments in each family. Select an instrument and click "Add".

The instrument you selected now appears in the second column. You can add more instruments or

voice parts if needed.
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The order of the instruments in the second column determines the order they appear in the score.

To change the order click on an instrument name and use the "Up" or "Down" buttons to move it

higher or lower. When you are done click "Next".

Key signature
If you are using the latest version of MuseScore the wizard asks for a key signature. Select the key

signature you need and click "Next" to continue.

Time signature, pickup, and number of measures

Set the time signature to the numbers you want. If your piece begins with a pickup then mark the

"Pickup measure" checkbox and adjust pickup time signature to indicate the actual duration of the

first measure.

If you know approximately how many measures you need you can specify that here. Otherwise

you can add or delete measure later.

Click "Finish" to create your new score.

Adjustments to score after creation
You can change any settings specified during the new score wizard even after you start working on

the score.

• To add or delete measures or create a pickup see Measure operations

• To change any text see Text editing. To add a missing Title (or other text item) use the menu

Create → Text → Title (or other text item)

• To add, delete, or change the order of instruments use the menu Create → Instruments....

See also: Key signature, time signature, clef.

Templates
The first screen of the new score wizard has an option to "Create new score from template" (see

Title and other text above for details). To create a score using this method select the template

option and click "Next" to continue.

The next screen shows a list of templates. Select a template and click "Next". Continue and finish

the new score wizard as usual.
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The template files are normal MuseScore files stored in the template folder. You can create your

own templates by saving MuseScore files to the template folder. On Windows the template folder

is usually located at C:\Program Files\MuseScore 0.9\templates. On Linux look under

/usr/share/mscore-xxx if you installed from the package manager. If you compiled mscore on

Linux then look under /usr/local/share/mscore-xxx.



7

Chapter 2

Basics

The "Getting started" chapter above guides you through the Installation and process for creating a

new score. The "Basics" chapter gives an overview of MuseScore and describes the general

methods for interacting with the score.

Note entry

Notes are entered in Note entry mode. First select a note or rest as start position for note entry.

When entering notes you are always replacing existing notes or rests. So the duration of a measure

does not change.

• N: Enters Note entry mode.

• Escape: Leaves Note entry mode.

After entering Note entry mode you should select the duration of the note you want to enter by

selecting a value from the note palette or by the corresponding keyboard shortcut.

In version 0.9.4 and later the keyboard shortcuts for selecting the note duration are:

• 1: 64th note (semi-demi-semiquaver)

• 2: 32nd note (demi-semiquaver)

• 3: 16th note (semiquaver)

• 4: Eighth note (quaver)

• 5: Quarter note (crochet)

• 6: Half note (minim)

• 7: Whole note (semibreve)

• 8: Double whole note (breve)

• 9: Longa

Notes are entered by typing: C D E F G A B C
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Space creates a rest: C D Space E

Notes are added to chords by holding Shift and entering a note name: C D Shift+F Shift+A E F

Beams are created automatically: Alt+1 C D Alt+2 E F G A

To change octaves use the following key combinations:

• Ctrl+Up: Increase the pitch of a note by one octave.

• Ctrl+Down: Decrease the pitch of a note by one octave.

MIDI keyboard
You can also insert pitches using a MIDI keyboard on Windows or Linux as of version 0.9.4.

Version 0.9.3 or earlier has support for MIDI keyboard on Linux only.

Copy and paste

MuseScore can copy individual notes or large selections of music. The 0.9.4 release includes many

improvements to copy-paste including support for shift-drag selections.

Copy

1. Click on the first note of your selection

2. Shift+click on the last note of your selection. A blue rectangle should highlight the region you

selected.

3. From the menu choose Edit → Copy

Paste

1. Click on the note or measure that you want your pasted selection to begin

2. From the menu choose Edit → Paste

Edit mode

Many elements in the score can be edited in Edit Mode :
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• Double Click: Starts Edit Mode

• Escape: Ends Edit Mode

Some elements show handles in edit mode which can be moved by mouse dragging or keyboard

commands.

Slur in Edit Mode:

Available keyboard commands:

• Left: Moves handle left one Space

• Right: Moves handle right one Space

• Up: Moves handle up one Space

• Down: Moves handle down one Space

• Ctrl+Left: Moves handle left 0.1 Space

• Ctrl+Right: Moves handle right 0.1 Space

• Ctrl+Up: Moves handle up 0.1 Space

• Ctrl+Down: Moves handle down 0.1 Space

• Shift+Left: Moves handle's tick anchor left

• Shift+Right: Moves handle's tick anchor right

• Tab: Goes to next handle

See also: Text editing, Slur, Bracket, Lines

Measure operations

Append
To add a measure to the end of the piece press Ctr+B. To add multiple measures use the menu

Create → Measures → Append Measures....

Insert
First select a measure then press Ins to insert a new empty measure before the selected one. To

insert multiple measures use the menu Create → Measures → Insert Measures....

Delete
To delete a measure you have to first select it in a special way. Press Ctrl on the keyboard as you

click on an empty part of the measure with the mouse. The measure is marked with a dotted line

indicating that you selected a "piece of time". Press Shift+Click to extend the selection. Pressing Del

removes the selected measures.

Properties
To edit the properties of a measure right click on an empty part of the measure and select

Measure Properties....
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Duration
Normally the nominal and actual duration of a measure is identical. A pickup (upbeat) measure

can have a different actual duration.

Irregular
An "irregular" measure is not counted in the measure numbering. Normally a pickup measure is

marked as "irregular".

Repeat count
If the measure is the end of a repeat you can define how often the repeat should be played.

Palette

You can show or hide the palette using the menu Display → Palette.

You can drag-and-drop palette symbols onto score elements.

Double clicking a palette symbol is equivalent to drag-and-dropping this symbol to each of the

selected elements on the score.

For example you can easily put a tenuto on several notes at once:

1. Select notes

2. Double click on the tenuto symbol in the attributes palette

Undo and redo

MuseScore has unlimited undo/redo functions.

The standard shortcuts are:

• Undo Ctrl+Z

• Redo Ctrl+Shift+Z

Or use the toolbar buttons:
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Export

A score can be exported via File → Save As... to several different formats:

Compressed MuseScore format (*.mscz)

MSCZ is the standard MuseScore file format and recommended for most uses. A score saved

in this format will not loose any information. The format is a ZIP-compressed version of

.msc files.

MuseScore format (*.msc)

MSC is the uncompressed version of the MuseScore file format. A score saved in this format

will not loose any information. However the file extension has file association conflicts on

Microsoft Windows and is blocked by some email providers since .msc files can also be a

type of Windows system file ("Management Saved Console"). This format is recommended if

you need to manually edit the file format using a text editor.

MusicXML (*.xml)

MusicXML is the universal standard for sheet music and can be used by most of the currently

available scorewriters including Sibelius, Finale, and more than 100 others. It is the

recommended format for sharing your sheet music between different scorewriters.

Compressed MusicXML (*.mxl)

Compressed MusicXML creates smaller files than regular MusicXML. Compressed

MusicXML is a newer standard and not as widely supported by other scorewriters at this

time.

MIDI (*.mid)

Musical Instrument Digital Interface (MIDI) is a format widely supported by sequencers and

music notation software. It is not a notation format so much of the information about the

score is cannot be saved in a MIDI format. To sharing files between different music notation

software use MusicXML.

PDF (*.pdf)

Portable Document Format (PDF) is ideal for sharing your sheet music with others who do

not need to edit the music. Most computer users already have a PDF viewer on their computer

so they will not need to install any extra software to see your score.

PostScript (*.ps)

PostScript (PS) is popular as a page description language used in printing.

PNG (*.png)

http://www.recordare.com/xml.html
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Portable Network Graphics (PNG) is a bitmap image format with native support on all major

operating systems and image software and popular on the web. As of version 0.9.3

Multi-page scores export a PNG file for every page.

SVG (*.svg)

Scalable Vector Graphics (SVG) can be opened by most web browsers (expect Internet

Explorer) and most vector graphics software. However most SVG software does not support

embedded fonts so the appropriate MuseScore fonts must be install to view these files

correctly.

LilyPond (*.ly)

LilyPond format can be opened by the Lilypond scrorewriter . However LilyPond export is

incomplete and experimental in the current versions of MuseScore.

http://lilypond.org
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Chapter 3

Notation

In the previous "Basics" chapter you learn how to enter notes and interact with the palette. The

"Notation" chapter describes the different types of notation in more detail including more

advanced music notation.

Accidental

Accidentals can be set or changed by dragging an accidental symbol from the accidental palette to

a note in the score.

If you only want to change the pitch of a note you can also select the note and press:

• Up: Increase the pitch of a note by one semitone.

• Down: Decrease the pitch of a note by one semitone.

• Ctrl+Up: Increase the pitch of a note by one octave.

• Ctrl+Down: Decrease the pitch of a note by one octave.

MuseScore automatically tries to set an appropriate accidental for the changed pitch. If you need to

manually correct an accidental or place an cautionary accidental (editorial accidental), then drag an

accidental from the accidental palette to the note. If you later change the pitch with cursor keys,

manual settings to the accidental are removed.

The menu function Notes → Pitch spell tries to guess the right accidentals for the whole score.
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Arpeggio

Arpeggios are set by dragging an arpeggio symbol from the arpeggio palette to a note of a chord.

Bar line

Change bar line type
Bar lines are changed by dragging a bar line symbol from the bar line palette to an bar line in the

score.

Create grand staff
To extend bar lines over multiple staves double click on a bar line to edit it (see Edit mode).

Click and drag the blue square down to the next staff.

Display of all staff bar lines updates when you leave edit mode.

See also: Measure operations

Beam

Beams are set automatically but the automatic setting can be overridden manually. Drag a beam

symbol from the beam palette to a note in order to change its beam behavior.

You can also first select a note and then double click the appropriate symbol in the beam palette.
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Start a beam at this note.

Do not end a beam a this note.

Do not beam this note.

Start a second level beam at this note.

See also: Cross staff beaming

Bracket

Delete
Select the bracket and press Del

Add
Drag a bracket symbol from the bracket palette to an empty space in the first measure of a system.

Change
Drag a bracket symbol from the bracket palette to an bracket in the score.

Horizontal offset
In version 0.9.4 or later you can adjust the horizontal placement of a bracket. Double click a

bracket and press Shift+Left or Shift+Right to move it left or right.

Edit
Double click on a bracket to enter edit mode, In edit mode you can drag the height of a bracket

to span arbitrary staves of a system.

Breath

To place a breath symbol drag it from the breath palette to a note in the score. The breath symbol

is placed before the note.
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Breath symbol in score:

Clef

Clefs are created or changed by dragging a clef symbol from the clef palette to a measure or

another clef. Use F9 to show or hide the palette sidebar.

Change
Drag a clef from the palette onto a clef in the score. You can also drag a clef from the score to

another clef of the score by using Shift + leftMouseButton + Drag.

Add
Drag a clef from the palette onto an empty part of a measure. This creates a clef at the beginning of

the measure. Drag a clef to a particular note to create a mid-measure clef. If the measure is not the

first measure in the staff it is drawn smaller.

Remove
Select a clef and press Del.

Note that changing a clef does not change the pitch of any note. Instead the notes are moved.

Cross staff beaming

In piano scores it is common to use both staves (bass and treble clef) to write a musical phrase.

This can be entered in MuseScore as follows:

First enter all notes in one staff:



17

Shift+Ctrl+Down moves the selected note or chord to the next staff

See also: Bar line for cross-staff bar lines (i.e. grand staff).

Drum notation

Example drum notation:

Grace note

Short grace notes (Acciaccatura) are painted as a small notes with a stroke through the stem.

Long grace notes (Appoggiatura) have no stroke. Both are placed before the normal-sized main

note.

Create a grace note by dragging a grace note symbol from the notes palette to a regular note on the

score.

See also: Grace note at Wikipedia

Hairpin

Hairpins are line objects. To create a hairpin first select a note to mark the start point.

http://en.wikipedia.org/wiki/grace_note
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• H: Creates a crescendo hairpin

• Shift+H: Creates a diminuendo hairpin (decrescendo)

You can also create hairpins by dragging a hairpin symbol from the line palette to a note head.

1. H creates a crescendo hairpin:

2. Double click switches to edit mode:

3. Shift+Right moves end anchor:

Key signature

Key signatures are created or changed by dragging a key symbol from the key palette to a

measure or existing key signature.

F9 toggles the palette window.

Change
Drag a key from the palette onto a key in the score. You can also drag a key from the score to

another key on the score by using Shift+leftMouseButton+Drag.

Add
Drag a key from the palette onto an empty part of a measure. This creates a key at the beginning of

the measure.

Remove
Select a key and press Del.
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Lines

The lines palette like other palettes works via "drag-and-drop". Use the mouse to drag the item

from the palette and drop it onto the score.

Change length

1. If you are in note entry mode then press N to leave note entry

2. Double click the line that you want to change

3. Move the handles using the following shortcuts

• Shift+Right to move the anchor right by one note (or measure)

• Shift+Left to move the anchor left by one note (or measure)

4. If you need to change the length visually without changing the notes or measures that the

line is anchored to then use the following shortcuts

• Right to move the handle right by one unit

• Left to move the anchor left by one unit

See also: Hairpin, Volta (1st and 2nd endings)

One-bar rest

When an entire measure is devoid of notes, a full measure (semibreve) rest is used.

To create a one-bar rest select a measure and press Del. All notes and rests on this measure are then

replaced by a one-bar rest.

Repeat

The start and end of simple repeats can be defined by setting appropriate bar lines. For instructions

on first and second ending measures see volta.

Playback
To hear repeats during playback make sure the "Play Repeats"
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button on the toolbar is selected. Likewise you can turn off repeats during playback by deselecting

the button.

In the last measure of a repeat you can set the property "Repeat Count" to define the number of

played repeats.

Text
Repeat text such as "D.C. al Fine" or "D.S. al Coda" is located in the repeats palette.

Slur

A slur is a curved line between two or more notes that indicates the notes are to be played without

separation. If you mean to join two notes of the same pitch then see Tie

Instructions

1. Select first note:

2. S creates a slur in Edit mode:

3. Shift+Right moves the slur end to the next note:

4. X flips the slur direction:

5. Escape ends Edit mode:
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The boxes or handles (displayed in the images for steps 2-4 above) can be adjusted with the

mouse. The two outer handles adjust the start and end of the slur. The two inner handles adjust the

contour of the slur.

A slur can span several systems and pages. Slur start and end is anchored to a note/chord or rest.

This means that if the notes move in a relayout, the slur moves too.

See also: Tie, Edit mode.

Tie

A tie is a curved line between two notes of the same pitch. If you want a curved line that spans

multiple pitches see Slur.

First method
Select first note:

+ creates a tie:

Second method
To create slurs during note entry press + after the first note of the tie.

Time signature

Time signatures are available in the main palette sidebar. You can drag and drop the times

signatures onto the score (see palette for general information on working with palettes in

MuseScore).

If you need a time signature not found in the sidebar palette then go to Create → Time... to

create your own. You can edit the upper and lower numbers in the Create Time Signature

pane.
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In most cases you'll only need to edit the first of the upper numbers. The additional upper numbers

are for additive meters which contain multiple upper numbers separated by a plus sign.

Pickup measures
There are occasions when the actual duration of a measure is different from the duration specified

by the time signature. Pickup measures are a common example. To change the actual duration of a

measure without displaying a different time signature see the Properties section of measure

operations.

Tremolo

Tremolo is the rapid repetition of one note or a rapid alternation between two or more notes. It is

indicated by strokes through the stems of the notes. If the tremolo is between two or more notes,

the bars are drawn between them.

The tremolo palette contains separate symbols for one note tremolos (shown with stems below)

and for two note tremolos (shown with no stem below).

In a two note tremolo every note has the value of the whole tremolo duration. To enter a tremolo

with the duration of a half note (minum) first enter two normal quarter notes (quavers). After

dragging a tremolo symbol to the first note the note values automatically double to half notes.

Tuplet

To create a triplet first create a note with a duration of the whole triplet. Then select the note and

press Ctrl+3 to change it to a triplet. Similarly Ctrl+5 changes the note to a quintuplet.

First select a note:

Ctrl+3 creates a triplet:

http://en.wikipedia.org/wiki/time_signature#additive_meters
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which can be further edited

Voices

Note: The MuseScore implementation of voices in 0.9.4 is not yet complete and subject to change.

Enter multiple voices per staff:

1. First start by entering the top voice (all the up-stem notes).

2. When you enter the notes some may have down-stems. If you are using version 0.9.4 or later

you do not need to worry about the stem direction at this point because they will flip

automatically when you add the second voice.

3. Now select the first note to move your cursor back to the beginning of the line.

4. Click on "Voice 2" button

and start entering the bottom voice (all the down-stem notes).

5. When you are done it should look like this:

When to use voices

• If you need stems pointing in opposite directions within a chord on a single staff

• If you need notes of different durations within a single staff, played simultaneously

Hidden spacer rests
To hide a rest right-click on the rest and select Set Invisible. If you have Display → Show

Invisible marked then the rest still shows in gray on your screen. The rest does not appear when

you print.

Volta

Volta brackets or first and second ending brackets are used to mark different endings for a

repeat.
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To place a volta bracket on the score drag-and-drop the item from the lines palette.

The brackets can span more than one measure. Double click the volta to enter edit mode and then

move the handles with:

• one measure left Shift+Right

• one measure right Shift+Left

These commands move the "logical" start or end of the volta which determine the bracketed

measures.

Other commands in edit mode also move the handles but do not change how the repeat is played.

If you move the handles, a dashed line from the logical position to the actual position is shown

Properties

Repeat list
This list determines which repeat the volta should be played.

If the volta is played in more than one repeat all repeat numbers must be listed and separated by a

comma (",").

Text
You can set an arbitrary volta text. Of course the text should correspond with the repeat list.
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Chapter 4

Sound and playback

MuseScore has "Sound and playback" capabilities built in. This chapter covers the playback

controls and ways to extend the instrument sounds beyond the built-in piano sound.

Play mode

MuseScore has an integrated sequencer and synthesizer to play your score.

By pressing the Play

button you enter Play mode. In Play mode the following commands are available:

• Toggle pause/play Space

• Seek to previous chord Left

• Seek to next chord Right

• Seek to previous measure Ctrl+Left

• Seek to next measure Ctrl+Right

• Rewind to start of score Home

• Toggle show play panel F11

Or via the menu: Display → Play Panel

Press the play button again to stop and exit Play mode.
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If you want to play instruments other than piano you have to change the MuseScore integrated

SoundFont with a more capable one in Edit → Preferences... → I/O tab. See SoundFont for

instructions.

SoundFont

MuseScore comes with a piano sound for play back. For more sounds, such as a violin or

percussion, you need a General MIDI SoundFont.

Overview
A SoundFont file can store any number of instrument sounds. Many SoundFonts are available on

the web. Look for one that covers the 128 sounds of General MIDI (GM).

The file size and sound quality of SoundFonts available on the web is varied. Larger SoundFonts

often sound better but may be too large to run on your computer. If you find MuseScore runs

slowly after installing a large SoundFont or your computer can't keep up during play back then

look for a smaller SoundFont. Below are three popular GM SoundFonts of different sizes.

• FluidR3_GM.sf2 (141 MB uncompressed), download Fluid-soundfont.tar.gz (129 MB)

• MagicSF_ver2.sf2 (67.8 MB uncompressed), see Big SoundFonts

• Unison.sf2 (27.9 MB uncompressed), see Big SoundFonts

Compression
Since SoundFont files are large they often are compressed into a variety of formats including .zip,

.sfArk, and .tar.gz. You need to decompress these files before they can be used.

• ZIP is standard compression format supported by most operating systems.

• sfArk is a compression format designed especially for compressing SoundFont files. Use the

special sfArk software to decompress it.

• .tar.gz is a popular compression format for Linux. Windows users can use 7-zip which

supports a wide variety of compression formats. Note that you need apply decompression

twice: once for GZip and once for TAR.

MuseScore settings
After finding and decompressing a SoundFont do not double click to open it since this does not set

up MuseScore. Instead move the file to a folder of your choosing, start MuseScore, and follow the

instructions below.

Go to Edit → Preferences... → I/O tab.

The initial Sound Font setting is :/data/piano1.sf2. Replace this with the location of your

new SoundFont (.sf2) file. Click on the Open icon to browse for the file and open it.

To apply changes click OK to exit the preferences panel. Quit and and reopen MuseScore for the

changes to take affect

http://en.wikipedia.org/wiki/general_midi
http://www.musescore.org/download/fluid-soundfont.tar.gz
http://www.personalcopy.com/sfarkfonts1.htm
http://www.personalcopy.com/sfarkfonts1.htm
http://www.melodymachine.com/sfark.htm
http://www.7-zip.org/
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Troubleshooting
If the toolbar play panel is greyed out or not visible follow the instructions below to get your

sound working again:

1. Make sure there is a check mark next to the Display → Transport menu item. You can add

or remove the check mark by clicking on the corresponding menu item. If this step does not

solve your problem continue with the next step below

2. If the play panel disappears after changing the SoundFont go to Edit → Preferences... →
I/O tab and click OK without making any changes, After restarting MuseScore the play

panel should reappear. This is a known bug with versions 0.9.3 or earlier.

Tempo

Play back tempo can be changed via the play panel or via tempo text in the score.

Play panel

• Display the play panel: Display → Play Panel

• Change the Beats per Minute (bpm) using the Tempo (Tmp) slider

Tempo text

• Select a note to indicate where the tempo text should be created

• From the main menu: Create → Text... → Tempo...

• Press OK to finish

Note that in versions 0.9.3 or earlier it is not possible to change the tempo text or BPM from the

initial Tempo Text dialog. However you can change both of these after you add a tempo text to the

score.

Existing tempo text can be changed by double clicking the text to enter edit mode.

Beats per minute (BPM) on existing tempo text can be adjusted by right clicking on the

text and selecting Tempo Properties...

Note: Tempo text in the score overrides a tempo setting in the play panel.
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Chapter 5

Text

The "Text" chapter covers lyrics, chord names, and other staff text. The previous chapter covers

text that affects playback tempo

Text editing

Double click on text to enter edit mode:

In text edit mode the following commands are available:

• Ctrl+B toggles bold face

• Ctrl+I toggles italic

• Ctrl+U toggles underline

• Up start superscript or end subscript if in subscript mode

• Down start subscript or end superscript if in superscript mode

• move cursor: Home End Left Right

• Backspace remove character to the left of the cursor

• Delete remove character to the right of the cursor

• Return start new line

• F2 Show text palette. The text palette can be used to enter special characters and symbols.

Text palette:
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See also: Chord name, Lyrics

Text style

Text elements are created from a Text Style. This style defines

the initial properties of text.

Text properties:

• Font family: Name of the font such as "Times New Roman" or "Arial"

• Point size: the size of the font in points

• Italic, bold, underline: font properties

• Anchor: page, time, notehead, system, staff

• Alignment: horizontal: left, right, center; vertical: top, bottom, center

• Offset: an offset to the normal anchor position

• Offset type: mm, space, or percent of page size

Text types:

• Title, subtitle, composer, poet: anchored to page

• Fingering: Fingerings are anchored to note heads.

• Lyrics: Lyrics are anchored to a time position.

• Chord name: Chord names are also anchored to a time position.

Chord name

Chord names can be entered by first selecting a note and then pressing Ctrl+K. This creates a

chord name text object for the selected chord.

1. Type Space to move to the next chord.

2. Shift+Space moves to the previous chord.

3. Ctrl+Space enters a space into the chord name text.

Chord names can be edited as normal text.
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Fingering

Fingering can be added to notes by dragging a fingering character from the fingering palette to a

note head in the score. Fingerings are normal text which can be edited like any other text.

Lyrics

1. First enter notes

2. Select first note

3. Type Ctrl+L and enter lyrics text for first note

4. Type Space at end of word to go next note

5. Type an hyphen - at end of syllable to go to next note. The syllables are connected with a

dash

6. Shift+Space moves to the previous note

7. Ctrl+Space enters a space into the lyrics text

8. Ctrl+- enters a hyphen (-) into the lyrics text

Syllables can be extended by an underline:

Entered with: soul, _ _ _ To Esc.

Lyrics can be edited as normal text.

See also: Text, Chord name.
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Chapter 6

Formatting

Break

Page breaks or line breaks (system breaks) can be applied by dragging a page break symbol or

line break symbol from the breaks palette to an empty space of a measure in the score. The break

happens after the marked measure. The green break symbols are visible on the screen but do not

appear on printouts.

Frame

Frames provide empty space outside of normal measures. They can also contain text or pictures.

MuseScore has two kinds of frames:

Horizontal

Horizontal frames break a system. The width is adjustable and the height equals the system

height. Horizontal frames can be used to separate a coda.

Vertical

Vertical frames provide empty space between or before systems. The height is adjustable and

the width equals the system width. Vertical frames are used to place title, subtitle or

composer. If you create a title, a vertical frame is placed before the first measure

automatically if it is not there already.

Create a frame
First select a measure. The command to insert a frame is found in the menu Create → Measures

. The frame is inserted before the selected measure.

Delete a frame
Select the frame and press Del.
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Edit frame
Double click the frame to enter edit mode. A handle appears which can be used to drag the size of

the frame.

Title frame in edit mode:
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Chapter 7

Support

How to report bug or ask for support

Before posting your support request:

• PLEASE, try to find a solution in support forum. Use search function.

• Try to find solution in the user handbook.

• If you are getting an error message, check list of common error messages.

• If you are posting error report, first try to reproduce the problem with the latest release. You

may also see the version history to check whether it has been fixed already.

When posting your request for support or reporting bug, please include as much of the following

information as you know:

• Version of MuseScore you are using and what operating system you are running it on.

• Try to describe precise steps that lead to the problem (where do you click, what keys do you

press, what do you see, etc.). If you are not able to reproduce the problem with the steps, it is

probably not worth reporting it as the developers will not be able to reproduce it (and solve)

either.

Licensed under the Creative Commons Attribution 3.0 license, 2002-2008 Werner Schweer and

others.
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