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LabPlot är ett program för två- och tredimensionella diagram utgående från matematiska funktioner eller för
dataanalys.
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Chapter 1. Introduktion

Table of Contents

LabPlot's revisionshistoria

LabPlot är ett program för två- och tre-dimensionell grafisk presentation av datamängder och funktioner.
LabPlot tillåter dig att arbeta med flera diagram, som vardera kan innehålla flera kurvor. Kurvorna kan skapas
från data eller från matematiska funktioner.

Samtliga inställningar för en fullständig uppsättning diagram kan sparas i projektfiler. Dessa projektfiler kan
öppnas med kommandoradsparametrar, genom att att utnyttja Arkiv meny, eller genom att dra och släppa.

Varje objekt (titel, förklaring, axlar, axeletiketter) kan dras med musen. Ett dubbelklick på ett objekt öppnar
motsvarande dialogruta så att alternativen för objektet kan ändras.

Inställningarna av ett diagram eller enskild kurva kan också ändras via Utseende-meny. Med
Redigerar-menyn kan ytterligare datamängder och funktioner inkluderas, vilka kan visas i såväl samma som i
skilda diagram.

LabPlot's revisionshistoria

Version 1.5.1 (March 27, 2006)

new analysis functions : noise, signal filter, auto-/crosscorrelation and capability analysis• 
"add graph" dialog in graph dialog• 
improved set-value dialog in spreadsheet• 
support for panel plots and improved surface and pie plot• 
much improved explorer dialog with drag and drop• 

• 
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save and restore sheets position/size in project• 
statistics on columns/rows and fitting in spreadsheets• 
new axes tic style and fill between curves• 
support for richtext in legend• 
save settings and update open dialogs• 
optional xml project format (will be used later as standard format)• 
lot of bug fixes• 

Version 1.5.0 (16 augusti 2005)

fler viktningar + residuer för regression/ickelinjär anpasssning• 
lagt till wavelet- och Hankeltransformer samt förbättrat analysfunktioner• 
förbättrade ytdiagram och qwt 3D-diagram• 
förbättrat uppträdande vid icke linjära skalor samt LaTeX-etikett stöd• 
import/export av data från/till PostgreSQL, mySQL, etc. via KexiDB• 
import av Origin opj-projekts (Endast Origins arbetsblad)• 
bättre stöd för skript• 
många buggfixar• 

• 

Version 1.4.1 (28 mars 2005)

icke-linjär anpassning av godtycklig användardefinierad funktion med upp till 9 parametrar• 
inställning av standardvärden för diagramstil och symboler• 
klona kurvor samt ta bort/klona diagram• 
förbättrade import/export-inställningar med stöd för binära data• 
ytterligare analysfunktioner : komprimering, hitta toppar, periodiska, säsongsmässiga• 
regression/icke-linjär anpassning av data med felstavar• 
snabbläge för stora datamängder och dataläge för att inspektera datapunkter• 
inzoomning/utzoomning, markör och förbättrade rutnät• 
maskera datapunkter i kalkylblad och diagram• 

• 

Version 1.4.0 (15 december 2004)

mångsidigt kalkylblad för dataimport, redigering m. m.• 
nytt 3D-diagram med rotering och färgkartor (via qwtplot3d-bibliotek)• 
dubbelbuffrad diagramritning (inget flimmer)• 
datamängdsåtgärder• 
import/export av mer än 80 bildformat (svg, fits,...) och bättre bildbehandling• 
direkt export till ps, eps, pdf via ghostscript• 
enkel skriptning via QSA• 

• 

Version 1.3.1 (30 augusti 2004)

direkt export till svg, eps och många grafiska format• 
stöd för triangeldiagram och polära diagram• 
lagt till (om)faltning och interpolation• 
bättre zoomning, felstavar i diagram och kommenterade värden• 
fler diagramsymboler och pensel• 
läsning och skrivning av netcdf-, cdf- och ljudfiler (wav, au, snd, aiff,...)• 
förbättrad kurvlistedialog• 
ny filinformationsdialog• 

• 

Version 1.3.0 (14 juni 2004)

många diagram per arbetsblad• 
hantering av tids- och datumformat• 

• 
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förbättrad inställning av axlar• 
förbättrade ytdiagram (täthet, kontur)• 
förbättrad icke-linjär anpassning• 
stöd för cirkeldiagram• 
förbättrad dokumentation• 
tysk handbok• 

Version 1.2.3 (16 februari 2004)

linjär regression och icke-linjär anpassning• 
förbättrad fouriertransform genom gsl eller fftw• 
intergrering, differentiering och histogram• 
skapa, redigera och flytta ritobekt med mus• 
läsning/skrivning av komrimerade data (gzip, bzip2)• 
KDE KPart for LabPlot project files• 
flera buggfixar samt förbättrad tysk översättning• 

• 

Version 1.2.2 (17 december 2003)

logaritmisk skala på axlar• 
stöd för ritobjekt• 
stöd för gsl's specialfunktioner och fördelningar• 
fouriertransformer via gsl• 
export till pdf, dxf m. m. via pstoedit• 
export till > 100 olika bildformat via ImageMagick• 
fler buggfixar• 

• 

Version 1.2.1 (26 oktober 2003)

rejält förbättrad användargränssnitt• 
better KDE integration• 
'richtext' titel- och axeletiketter• 
förbättrade 3D-diagram• 
nya analysfunktioner• 
bättre läsning av data• 
ställa in och spara användarinställningar• 
exempel• 

• 

Version 1.2.0 (8 september 2003)

ny förbättrad intern diagramstruktur• 
satsanalysstöd för funktioner med flera parametrar• 
nytt ytdiagram med stöd för kontur och förklaring• 
stöd för JPEG2000 och tiff• 
användarhandbok (denna handbok)• 
fler buggfixar• 

• 

Version 1.1.1 (26 juli 2003)

läsning av matrisdata• 
täthetsdiagram från funktion och data• 
satsanalysverktyg helt omskrivet• 
färglagd och skalad utskrift• 
exportera diagram som grafik• 
mer flexibel läsning av data• 
förbättrad etikett för axelstreck (format och läge)• 

• 
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fler buggfixar• 
Version 1.1 (22 juni 2003)

fler objektattribut (titelfärg, rutnätsfärg m. m.)• 
stöd för 2D-felstavar• 
drag och släpp för titeln, för axlarna med riktig omskalning• 
förbättrad sparning och öppning av diagram i en projektfil• 
många buggfixar• 

• 

Version 1.0.3 (11 maj 2003)

Diagramlista i menyverktygslisten• 
förbättrad hantering av arbetsyta• 
drag och släpp för förklaringen• 
redigeringsdialog för att redigera data• 

• 

Version 1.0.2 (4 april 2003)

flyttning av diagram med verktygsknappar• 
skalning av diagram med verktygsknappar• 
öppning av dialoger via musklick• 
förbättrad förhandgranskning vid utskrift• 

• 

Version 1.0.1 (18 mars 2003)

förhandgranskning vid utskrift inlagd• 
infört kurvetikett skild från namn• 

• 

Version 1.0 (3 mars 2003; omdöpt till LabPlot)

support for KDE 3.0 and KDE 2.x• 
automake och autoconf skript (./configure)• 

• 

Version 0.9.x (26 februari 2003)

förbättrad datadialog• 
spara och öppna ett diagram• 
börjat med i18n (de)• 
started with migration from Qt? to KDE• 
förbättrad listdialog• 
ändring av data och funktionskurvor i listdialog• 
stöd för rutnät i 2D och 3D diagram• 

• 

Version 0.4.0 (7 oktober 2002)

stöd för 3D-diagram• 
använder kurvlista för lagring av alla kurvor i ett diagram• 
bättre skalning av hela diagrammet• 
ny klass 'GraphM' för stöd av matrisdata• 

• 

Version 0.2.1 (30 juni 2001)

förklaring i diagram• 
listdialog för alla kurvor i ett diagram• 

• 

Version 0.2 (16 juni 2001)

första 'PlotWidget' med enkel kurva• 
skapa data via funktionsdialog• 

• 
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Version 0.1 (20 maj 2001; första utgåvan under namnet QPlot)• 

Chapter 2. Egenskaper

Detta kapitel avser att utgöra en fullständig lista med LabPlots egenskaper.

Uppritning 2D och 3D data- och funktionsdiagram

flexibel läsning/skrivning av data i olika format (inklusive cdf, netcdf, ljud, binärt, bilder)• 
läsning och skrivning av bilder och komprimerade data• 
utvidgad satsanalys för att skapa 2D- och 3D-funktioner• 
stöd för alla funktioner och konstanter i GNU Scientific Library (GSL)• 
skapa yt-, polära, triangel- och cirkeldiagram från funktioner och datafiler• 
flexibla 3D-diagram med rotation• 
många diagram per arbetsblad• 
datamängdsåtgärder• 
snabbläge för stora datamängder och dataläge för att inspektera datapunkter• 

Lätt redigering av diagram

klona kurvor samt ta bort/klona diagram• 
mångsidigt kalkylblad för datamanipulation• 
dubbelklicka för att öppna detajlerade dialogrutor för alla inställningar• 
samtliga objekt kan dras med mus• 
direkt skalning och förflyttning av diagram• 
Stöd för LaTeX och richtext etiketter• 
utvärdering av uttryck och direkt redigering av data• 
statistisk information om data• 
ritobjekt redigerbara med mus• 
fri- eller panoreringszoomning, maskering av datapunkter samt markör• 
"add graph" dialog in graph dialog• 
support for panel plots• 

Analys av data och funktioner

medelvärdesbildning, utjämning och utglesning av data• 
komprimerings- periodisk och säsongsmässig analys• 
hitta toppar• 
interpolation (spline, m. m.)• 
differentialer• 
integrering• 
histogram• 
regression (upp till 10:de ordningen)• 
icke-linjär anpassning (även vilken användardefinierad funktion som helst med upp till 9 parametrar)• 
fourier-, Hankel- och wavelettransform• 
faltning och omfaltning• 
bildmanupulation• 
noise, signal filter and auto-/crosscorrelation• 
capability analysis• 

Handbok för LabPlot
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LabPlot projektfiler

stöd för skilda arbetsblad och kalkylblad genom MDI• 
spara och öppna samtliga arbetsblad och kalkylblad i en projektfil (*.lpl)• 
redigerbar projektinformation• 
export av arbetsblad som bild, ps, eps, svg, pdf och många andra format (med pstoedit eller
ImageMagick)

• 

import/export av data från/till PostgreSQL, mySQL, etc. via KexiDB• 
flertal exempel på projektfiler• 
optional xml project format (will be used later as standard format)• 
import av Origin opj-projekt• 

KDE look and feel

inställning av standardvärden för diagramstil och symboler• 
utskrift och inbäddad utskriftsförhandsgranskning• 
stöd för drag och släpp• 
KPart för LabPlot projekt• 
KDE handbook (English and German)• 
complete scriptable using Qt? Script for Applications (QSA)• 

Chapter 3. Använda LabPlot
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Kommandoradsalternativ

Specificera en fil

När LabPlot startas från kommandoraden kan du skicka med namnet på en projektfil:

LabPlot [fil.lpl...]

Övriga kommandoradsalternativ

Följande kommandoradshjälpalternativ finns

LabPlot --help
Detta listar är de mest grundläggande alternativen för kommandoraden.

Handbok för LabPlot
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LabPlot --help-qt
This lists the options available for changing the way LabPlot interacts with Qt?.

LabPlot --help-kde
This lists the options available for changing the way LabPlot interacts with KDE.

LabPlot --help-all
Detta listar samtliga kommandoradsalternativ.

LabPlot --no-splash
do not show the splash screen

LabPlot --author
Listar LabPlot's författare i terminalfönstret

LabPlot --version
Lists version information for Qt?, KDE, and LabPlot. Also available through LabPlot -v

Kalkylbladet

Kalkylbladet är den viktigaste funktionen hos LabPlot, när man arbetar med data. För att kontrollera och
omvandla data innehåller kalkylbladet en anpassningsbar tabell. Varje kolumn i tabellen har en given etikett
och kan kopplas till ett format (som dubbel eller datum-tid format).

Du kan importera via importdialog. Vilken kalkylfunktion som helst kan nås via innehållsmenyn
(högerklicka). Du kan klippa ut, kopiera och klistar in mellan kalkylblad, fylla ut, normalisera och omvandla
data samt slutligen åstadkomma diagram från dina data. Du kan naturligtvis exportera data.

Sedan version 1.4.1 kan du maskera vissa datapunkter i kalkylbladet som då utesluts vid diagramritningen.
Datapunktsmaskeringen kan senare bli påverkad i kurvlistdialogen.

Arbetsbladet

Handbok för LabPlot
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Arbetsbladet innehåller samtliga diagram och ritobjekt. Du kan anpassa arbetsbladet i arbetsbladsdialogen.

Arbetsbladet kan innehålla flera diagram med olika egenskaper. För att arrangera eller övertäcka diagram i ett
arbetsblad så används de två första undermenyerna till "Utseende"-menyn.

Drag och släpp

LabPlot supports the Drag and Drop protocol of KDE and Qt?. This means that you can open a project by
dragging their symbols onto the LabPlot window. Project files should have the extension .lpl.

Positionering med mus

LabPlot stöder dragning med mus av axlar, titel, förklaring och axeletiketter.

För att flytta ett objekt måste man klicka på dess yta med vänstra musknappen. När musen flyttas med vänstra
musknappen nedhållen kommer diagrammet att kontinuerligt uppdateras för att visa den nya positionen. När
musknappen släpps stannar objektet kvar där det är.

Statusrad

Den horisontella och vertikala positionen hos muspekaren i diagramområdet visas i data enheter till vänster i
statusraden i botten på LabPlot-fönstret.

Sidoverktygslist

Från sidoverktygslisten kan många funktioner enkelt nås. Du kan här välja att zooma, flytta eller skala ett
diagram. Även några mera utökade funktioner som dataläge (att inspektera enstaka datapunkter) eller maskera
datapunkter kan väljas här. För mer information titta här.

Chapter 4. Kommandoreferens

Table of Contents

Arkivmenyn
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Redigeringsmenyn
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Arkivmenyn

File->New (Ctrl-n)
Skapar en ny LabPlot-projektfil.

I en projektfil är alla inställningar och alla diagram lagrade i ASCII-format.
File->Open (Ctrl-o)

Öppnar en LabPlot-projekt fil.
Arkiv->Öppna senaste

Öppnar en nyligen använd LabPlot-projektfil.

Här listas de tio senaste projektfilerna.
File->Save (Ctrl-s)

Sparar det aktuella projektet.

Om du inte har sparat projektet innan sparas projektet under ett tillfälligt filnamn.
File->Save As (Ctrl-a)

Sparar det aktuella projektet under ett annat namn.
File->OpenXML

Open project from a LabPlot XML file.
File->SaveXML

Save project to a LabPlot XML file.
File->Project Infos (Alt-v)

Denna dialog ger dig möjlighet att övervaka och ändra vissa projektrelaterade alternativ som titel,
författare, skapelsedatum, m. m. Denna information sparas i projetfilen och kan användas till att
bevara ytterligare information om ett projekt.

File->Project Explorer (Ctrl->)
Denna dialog ger en överblick av projektets struktur. I en framtida utgåva kan det finnas ytterligare
funktionalitet här såsom tillägg av kurvor, diagram eller arbetsblad.

File->Import (Ctrl-Shift-l)
Importera data in till det aktiva kalkylbladet

Detta objekt kan utnyttjas till att importera data in i LabPlot. Vänligen läs mer i importdialog-delen.
File->Import OPJ project (Ctrl-Shift-j)

Importera OPJ-projekt
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Denna funktion kan användas för att importera Origin OPJ-projekt till LabPlot.
File->Export to Image (Ctrl-r)

Sparar det aktiva diagrammet som grafik

Här har du möjlighet att spara det aktiva diagrammet i ett skilda bildformat. F. n. stöds : bmp, jpg,
jpg2000, pgm, png, ppm, tiff, xbm och xpm.

File->Export to ... (Ctrl-o)
Sparar det aktiva diagrammet i ett specialformat.

F. n. stöds : Postscript (PS), Encapsulated Postscript (EPS), Portable Document Format (PDF),
Scalable Vector Graphics (SVG) och det egna QPicture Format (PIC).

File->Export via pstoedit (Alt-e)
Exporterar det aktiva diagrammet i skilda format.

Här har du möjlighet att exportera det aktiva diagrammet till skilda format via pstoedit. Stöd för : dxf,
fig, eps och många flera.

File->Export via ImageMagick (Alt-i)
Exportera det aktiva diagrammet till skilda bildformat.

Här har du möjlighet att exportera det aktiva diagrammet till skilda bildformat via ImageMagick. Stöd
för mer än 100 olika format! För mer information hänvisas till dokumentation för ImageMagick.

File->Print (Ctrl-p)
Skriver ut det aktiva diagrammet.

Här öppnas en utskriftsdialog, där du kan välja skrivare, olika pappersstorlekar m. m.
File->Print Preview (Alt-p)

Öppnar en förhandsgranskning av utskrift.

Här öppnas en inbyggd förhandsgranskning av utskriften av det aktiva diagrammet i A5, landskap.
Om förhandsgranskning av utskrift är aktiverad kan du stänga den här.

File->Quit (Ctrl-q)
Avsluta LabPlot.

Redigeringsmenyn

Edit->New 2D Plot (Ctrl-Shift-n)
Detta används för att öppna ett tomt 2D-diagram i det aktuella arbetsbladet.

Edit->New Surface Plot (Alt-z)
Detta används för att öppna ett tomt ytdiagram i det aktuella arbetsbladet.

Edit->New 3D Plot (Ctrl-m)
Detta används för att öppna ett tomt 3D-diagram i det aktuella arbetsbladet.

Edit->New QWT 3D Plot (Ctrl-Shift-q)
Detta används för att öppna ett tomt QWT 3D-diagram i det aktuella arbetsbladet.

Edit->New Pie Plot (Alt-.)
Detta används för att öppna ett tomt cirkeldiagram i det aktuella arbetsbladet.

Edit->New Polar Plot (Ctrl-Shift-o)
Detta används för att öppna ett tomt polärdiagram i det aktuella arbetsbladet.

Edit->New Ternary Plot (Ctrl-Shift-t)
Detta används för att öppna ett tomt triangeldiagram i det aktuella arbetsbladet.

Edit->Delete Active Plot (Alt-q)

Handbok för LabPlot
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Detta används för att ta bort det aktiva diagrammet i det aktiva arbetsbladet.
Edit->Clone Active Sheet (Alt->)

This item can be used to clone the active spreadsheet / worksheet.
Edit->New Spreadsheet (Ctrl-Shift-S)

Detta används för att öppna ett nytt kalkylblad.
Edit->New Worksheet (Alt-x)

Detta används för att öppna ett nytt arbetsblad.
Plot->Graph List (Ctrl-g)

Opens the graph list dialog.

In the list dialog you can manipulate the graphs of the active plot. This dialog can also be reached by
double clicking on a plot.

Plot->Plot List (Ctrl-Shift-.)
Opens the plot list dialog.

In the plot list dialog you can manipulate the plots of the active worksheet.
Diagram->Nytt diagram från funktion

Opens the function dialog.

This item opens the function dialog to create a plot from a user defined function.
Plot->New Plot from Function->2DFunction (Ctrl-e)

Opens the 2d function dialog.

This item opens the function dialog to create a 2 dimensional graph from a user defined function.
Plot->New Plot from Function->2D Surface Function (Ctrl-u)

Opens the 2d surface function dialog.

This item opens the function dialog to create a 2 dimensional surface graph from a user defined
function.

Plot->New Plot from Function->Polar Function (Alt-<)
Opens the polar function dialog.

This item opens the function dialog to create a 2 dimensional polar graph from a function.
Plot->New Plot from Function->3D Function (Ctrl-f)

Opens the 3d function dialog.

This item opens the function dialog to create a 3 dimensional graph from a user defined function.
Diagram-> Nytt diagram från data

Opens the data dialog.

This item opens the data dialog to create a plot from data.
Plot->New Plot from Data->2D Data (Ctrl-d)

Opens the 2d data dialog.

This item opens the data dialog to create a 2 dimensional graph from a data file. You can specify a lot
of options for reading data so you should be able to read any type of ASCII data here.

Plot->New Plot from Data->2D Surface Data (Alt--)
Opens the 2d surface data dialog.

This item opens the data dialog to create a 2 dimensional surface graph from a data file.
Plot->New Plot from Data->Pie Data (Alt-,)

Handbok för LabPlot

Redigeringsmenyn 13



Opens the pie data dialog.

This item opens the data dialog to create a 2 dimensional pie graph from a data file.
Plot->New Plot from Data->Polar Data (Ctrl-,)

Opens the polar data dialog.

This item opens the data dialog to create a 2 dimensional polar graph from a data file.
Plot->New Plot from Data->Ternary Data (Ctrl-Shift-Y)

Opens the ternary data dialog.

This item opens the data dialog to create a 2 dimensional ternary graph from a data file.
Edit->New Plot from Data->3D Data (Ctrl-i)

Opens the 3d data dialog.

This item opens the data dialog to create a 3 dimensional graph from a data file. You can specify a lot
of options for reading data so you should be able to read any type of ASCII data here.

Plot->New Plot from Data->QWT 3D Data (Ctrl-Shift-B)
Opens the QWT 3D data dialog.

This item opens the data dialog to create a 3 dimensional qwt plot from a data file.
Diagram->Snabbläge

Toggles the speed mode setting

This item can be used to switch the speed mode on or off. The speed mode can be used to accelerate
the drawing for large datasets by drawing only a limited number of data points. The number of
datapoints can be selected in the settings dialog.

Edit->Clear (Ctrl-c)
Tömmer det aktiva diagrammet. Här tas alla kurvor i det aktiva diagrammet bort och du får ett tomt
diagram såsom vid "Nytt 2D/3D/Yt/cirkeldiagram".

Om det aktiva bladet är ett kalkylblad töms det också.
Edit->Close (Ctrl-w)

Stänger det aktiva bladet. Här kan du även stänga förhandsgranskningen av utskrift.

Visamenyn

Denna meny innehåller alla funktioner, som även återfinns i sidoverktygslisten.

Kalkylbladsmenyn

This menu contains all the items that can also be found in the context menu (right mouse) of a spreadsheet. If
no spreadsheet is active, you can add a new spreadsheet.

Analysmenyn

Titta även på den detaljerade informationen om analysfunktioner.

Analysis->Evaluate Equation (Ctrl-#)
Lets you evaluate any equation
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Analysis->Data set operations (Ctrl-Shift-d)
Opens the Operations Dialog

Here you can operate on data sets that means add or multiply the values of different graphs.
Analysis->Periodic->Periodic Function (Ctrl-Shift-k)

Opens the Periodic Dialog

Lets you investigate periodic data.
Analysis->Periodic->Seasonal (Ctrl-Shift-u)

Opens the Seasonal Dialog

Lets you compress periodic data.
Analysis->Peak find (Ctrl-Shift-x)

Opens the Peak Find Dialog

Here you can find peaks in a data set.
Analysis->Histogram (Alt-h)

Opens the Histogram Dialog

Here you can create a histogram of any graph. Choose the range and bins for the histogram in this
dialog.

För att kunna använda detta måste GSL vara installerat.
Analysis->Interpolation (Alt-i)

Opens the Interpolation Dialog

Here you can interpolate any graph. You can choose the type of interpolation the range and the
number of points for the resulting function in this dialog.

För att kunna använda detta måste GSL vara installerat.
Analysis->Differences (Alt-d)

Opens the Differences Dialog

Here you can create a graph of numerical differences for selected data (derivation of a function).
Analysis->Integration (Alt-n)

Opens the Integration Dialog

Here you can numerical integrate the selected graph. Define the needed region or use the active region
(can be defined under the appearance menu.)

För att kunna använda detta måste GSL vara installerat.
Analysis->Filter->Average (Alt-a)

Opens the Average Dialog

Here you can create a new graph from the averaged data of any other graph.
Analysis->Filter->Smooth (Alt-s)

Opens the Smooth Dialog

Here you can create a new graph from the smoothed data of any other graph.
Analysis->Filter->Compress (Ctrl-Shift-h)

Opens the Compress Dialog
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Compress data sets.
Analysis->Filter->Prune (Alt-r)

Opens the Prune Dialog

Here you can create a new graph from the pruned data of any other graph.
Analysis->Filter->Noise (Alt-r)

Opens the Noise Dialog

Lets you add a certain noise to your data.
Analysis->Filter->Signal Filter (Alt-r)

Opens the Signal Filter Dialog

Lets you apply a (signal) filter to your data.
Analysis->Transform->FFT (Alt-f)

Opens the FFT Dialog

Here you can make a fast fourier transform of the selected graphs. If supported on your platform you
can choose what library is actually used for the fourier transform (GNU scientific library (gsl) or the
Fastest Fourier Transform in the West (fftw)). You can make forward or backward transform, make
the x-Axis index, frequency or period and create the y-axis as magnitude, real, imaginary or phase.

För att kunna använda detta måste GSL vara installerat.
Analysis->Transform->Convolution/Deconvolution (Alt-C)

Opens the Convolution Dialog

In this dialog you can make a convolution/deconvolution of one graph with another. The used
x-values can be selected.

För att kunna använda detta måste GSL vara installerat.
Analysis->Transform->Auto-/Crosscorrelation (Ctrl-+)

Opens the Correlation Dialog

In this dialog you can make an auto-/crosscorrelation of one/two graphs.

För att kunna använda detta måste GSL vara installerat.
Analysis->Transform->Wavelet Transform (Ctrl-Shift-<)

Opens the Wavelet Dialog

För att kunna använda detta måste GSL vara installerat.
Analysis->Transform->Hankel Transform (Ctrl-Shift->)

Opens the Hankel Dialog

You need gsl >= 1.6 installed to use this.
Analysis->Statistics->Capability Analyis (Alt-;)

Opens the Capability Dialog

För att kunna använda detta måste GSL vara installerat.
Analysis->Regression (Alt-l)

Opens the Regression Dialog
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In this dialog you can make a regression of your data with different models and weight. The region
can be defined here to.

För att kunna använda detta måste GSL vara installerat.
Analysis->Nonlinear Fit (Alt-t)

Opens the Nonlinear Fit Dialog

With this dialog you can make a nonlinear fit of your data. Currently 12 different models and any user
defined model with up to 9 parameter can be selected. Start values, steps and tolerance for the
non-linear least-square fit using gsl can be set.

För att kunna använda detta måste GSL vara installerat.
Analysis->Image Manipulation (Ctrl-Shift-g)

Opens the Image Manipulation Dialog

With this dialog you can manipulate matrix or image data as image. Operations like rotate, scale,
sharpen or brighten can be performed here. Please see the analysis function overview.

Utseendemenyn

Appearance->Arrange Plots (Alt-y)
Opens the arrange dialog.

Here you can specify how to arrange plots on a worksheet.
Appearance->Overlay Plots (Ctrl--)

Opens the overlay dialog.

Here you can exactly overlay a plot onto another.
Appearance->Plot Settings (Ctrl-j)

Opens the plot dialog.

Here you can change the settings of the active plot.
Appearance->Worksheet Settings (Alt-w)

Opens the worksheet dialog.

Here you can make the settings of the active worksheet.
Appearance->Axes Settings (Ctrl-b)

Opens the axes dialog.

Here you can change the settings of the axes in a plot.
Appearance->Title Dialog (Ctrl-t)

Opens the title dialog.

Here you can change the settings of the title in a plot.
Appearance->Legend Dialog (Ctrl-l)

Opens the legend dialog.

Here you can change the settings of the legend in a plot.
Appearance->Drawing objects (Alt-o)

Opens the objects dialog.

Handbok för LabPlot

Utseendemenyn 17



Here you can add new drawing objects and change their settings.

Ritmenyn

I denna meny kan baslinje och område för ett diagram definieras. Även 5 skilda typer av ritobjekt kan enkelt
skapas här.

Med "Skapa baslinje" kan du skapa en baslinje, som används för att ifyllnad av kurvor och för integrering.
Med "Skapa område" kan ett område definieras. Ett område används för icke-linjär anpassning, integration m.
m.

Med de 5 andra sakerna kan olika ritobjekt enkelt skapas med musen. Följ bara tipsen på statusraden.

Bladlistamenyn

Denna meny visar dig en lista med alla arbetsblad och kalkylblad i ett projekt. Du kan välja det aktiva (som
visas) bladet här.

Diagramlistemenyn

Denna meny visar dig en lista med alla diagram i ett arbetsblad. Du kan direkt ändra inställningar för ett
diagram genom att välja motsvarande funktion här.

Skriptmenyn

Under denna meny samlas allt som kan användas för att manipulera skript till att automatisera
LabPlot-funktioner

Check out the Scripting Chapter for using the scripting interface of LabPlot

Script->Load Script (Ctrl-Shift-c)
Load and Execute a Qt? Script for Applications (QSA) script (*.qs).

Script->Open QSA Workbench (Ctrl-Shift-w)
Öppnar en "QSA workbench" för att kunna skapa och redigera QSA-skript (*.qs).

Inställningsmenyn

Denna meny ger dig förmåga att ändra användarinställningar.

Settings->Fullscreen (Ctrl-Shift-f)
Visa arbetsbladet i helskärmsläge.

Settings->Show Menubar (Ctrl-m)
Växla menyraden.

Inställningar->Anpassa LabPlot
Konfigurera användarinställningar i LabPlot. Standardstil standardsymbol för 2D och ytdiagram kan
även ställas in här.

Inställningar->Inställningar
Spara alla användarinställningar i LabPlot.
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Hjälpmenyn

Hjälp->Innehåll (F1)
Här är innehållet hjälpen till LabPlot tillgängligt.

Hjälp->Exempel
Här hittar du många exempel på LabPlot-projekt.

Hjälp->Om LabPlot
Visar viktig information om LabPlot.

Huvudverktygslist

Huvudverktygslisten innehåller det viktigaste sakerna du kan hitta i de olika menyerna. Du kan anpassa visade
saker i Inställningar->Ställ in verktygslistsdialogen

Sidoverktygslist

LabPlots sidoverktygslisten innehåller följande knappar:

Knapp Åtgärd
Lins förstorningslins
Hand panoreringszoom
dataläge inspektera enstaka datapunkter.
maskera data välj datapunkter som skall maskeras.
X Autoskala X.
Y Autoskala Y.
Z Autoskala Z.
+ zooma in.
- zooma ut.
Vänster Flyttar alla kurvor till vänster.
Höger Flyttar alla kurvor till höger.
Upp Flyttar alla kurvor uppåt.
Ner Flyttar alla kurvor neråt.
X+ Ökar förstorningen i X.
X- Minskar förstorningen i X.
Y+ Ökar förstorningen i Y.
Y- Minskar förstorningen i Y.
Z+ Ökar förstorningen i Z.
Z- Minskar förstorningen i Z.

Chapter 5. Dialogerna
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Funktion

Dialogen Funktion används till att skapa och genomföra inställningarna för funktionsdiagram. Den ser likadan
ut för 2D-, yt-, cirkel- och 3D-diagram. Endast några få diagramspecifika saker skiljer. Speciellt är stilen skild
för ytdiagram.

Den första redigeringsraden innehåller uttrycket för diagramfunktionen. Det inmatade uttrycket utvärderas av
en kraftfull satskontrollerare. För en komplett lista av understödda funktioner hänvisas till funktioner.

den andra redigeringsraden är till för inställning av etiketten för den skapade kurvan. Det är denna etikett du
får se i förklaringen.

I avsnittet "Intervall" och "Antal punkter" kan du välja intervall och antal punkter för den skapade funktionen.

Med de återstående stilmallarna kan du påverka funktionens utseende. Om du skapar en normal funktion
definierar det första valet linjestil (Linjer,IngaLinjer, Steg, Lådor, Impulser, Y-lådor), färgen och om du vill
ha den fylld (med en annan färg). De övriga delarna väljer symbol för plotpunkter, med färg, storlek och om
den skall fyllas och i så fall med vilken färg. Om du skaper ett ytdiagram, har du möjligheten att välja om du
vill visa ett täthetsdigram eller ett konturdiagram. Sedan kan du välja antal nivåer för konturdiagrammet och
färgskala för täthetsdiagrammet.

För att ändra inställningarna hos en funktion måste du välja ändringsknappen i listdialogen. För att ändra typ
av ytdiagram kan du även använda "Diagraminställnings"-dialogen.

Sedan version 1.4.0 använder LabPlot 'QWT 3D Plot' vilket bör föredragas jämfört med den enkla
3D-diagrammet.

Data

Dialogen Data används till att skapa kurvor utgående från datafiler.
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Denna dialog ser nästan ut som funktionsdialogen. Det finns dock vissa skillnader. Du måste välja den datafil,
som skall öppnas, i den första redigeringsraden. Du kan använd "Nytt"-knappen till att öppna en fildialoga för
detta. I "Läs från kolumn"-avsnittet kan du mata in från vilken kolumn du vill läsa motsvarnde värden. Om du
är osäker använd kontrollknappen till att titta på datafilen. Du kan även välja från vilken rad du skall läsa data
och vilka skilljetecken som används. "Auto"-skillnad upptäcker alla kombinationer av 'whitespaces'.

När du använder "y1 | y2 | y3 | ..." i "läs som"-valet läses y-värdena från en rad i datafilerna.

LabPlot supports the reading of images (all Qt? supported formats) and compressed data too (gzip, bzip2). for
images you should select "matrix" to read the data of the image.

Sedan version 1.3.1 kan LabPlot även läsa netcdf-, cdf- och ljudfiler (*wav, *.au, *.snd,...) För netcdf- och
cdfdata välj bara variablerna i x, y m. m. redigeringsraderna och eventuellt kontrollera det i "kontrollera
data"-dialogen. För att hitta rätt variabler kan du använda filinfodialogen till att kontrollera innehållet i
netcdf/cdf-filen. När du läser ljuddata välj bara 1 för tid, 2 för första kanalen och 3 för andra kanalen. 0
innebär givetvis indexliknade läsning av vilken annan datafil som helst.

"Läs som"-avsnittet väljer typ av data i datafilen. "Kurvtyp" väljer typ av kurva som skall skapas. Från
x-y-data kan du endast göra 2-dimensionella diagram. Från x-y-z-data kan du skapa 'fel'- och ytdiagram (2D
datadialog) eller täthets-, kontur- eller 3D-diagram (3D datadialog). Från matrisdata kan du skapa täthets-,
kontur- (2D datadialog) eller 3D-diagram (3D datadialog).

Sedan version 1.4.0 använder LabPlot 'QWT 3D Plot' vilket bör föredragas jämfört med den enkla
3D-diagrammet.

Diagraminställningar

I diagramdialogen kan du manipulera diagrammen i ett arbetsblad. Du kan klona eller ta bort diagram här.

Diagramlista

Listdialogen är centralpunkt vid hanetring av de olika kurvorna i ett diagram. Här får du en överblick av
samtliga kurvor och du kan manipulera dem. Du kan nå listdialogen via Diagram->Kurvlistedialog-menyn
eller genom att dubbelklicka i diagrammet. Alla omtalade funktioner kan nås i alla listdialoger med right
mouse button

Med "Visa/dölj" kan du växla mellan tillstånden för alla valda kurvor. Bara "Visade"-kurvor är synliga i
diagrammet.. Autoskalningsfunktionen använder endast de synliga kurvorna.

Med knapparna "Lägg till datafil" och "Lägg till funktion" kan du addera kurvor utgående från data eller
funktion till diagrammet. (se funktionsdialog eller datadialog. ) Med "Tag bort" kan du enkelt radera den
valda kurvan. Med "Ändra" kan du ändra inställningar för den valda kurvan. Om du vill kopiera en befintlig
kurva så använder du "Klona"-knappen.

"Export"-knappen öppnare dump dialog för att exportrera en kurva till en fil och "Redigera"-knappen tar dig
till redigeradialog.

Med "Växla maskering" och "Avmaskera allt" kan du ändra maskeringen för olika datapunkter.

"Statistik"-knappen visar viss statistik över de valda kurvorna.
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Varje manipulation kan även nås via höger musknapp. Multipelval är möjligt.

Add Graph

Here you can add graphs from another worksheet or from any spreadsheet.

Importdialog

Med importdialogen kan du importera data till LabPlot.

I redigeringsraden kan du specificera en eller flera datafiler för läsning. Med knappen för "Filinformation"
visas viss information om de valda filerna. Du kan även specificera åtskillnadstecken (t. ex. ",") och
kommentarsradstecken. Begynnelse- och slutrader för läsning kan även ställas in här.

Sedan version 1.4.1 av LabPlot kan du välja fördefinierade filter för olika standardformat, vilka väljer
samtliga behövliga inställningar.

Redigera

Med redigeringsdialogen kan du enkelt redigera en kurvas data. Du kan nå denna dialog via listdialog.

Tabell i den övre delan visar dig alla data. Här kan du välja vilken rad och kolumn du skall redigera. Du kan ta
bort eller sortera valda rader i stigande eller fallande ordning med knapparna under tabellen. Du kan även
utvärdera ett uttryck till valda rader och kolumner. Här används samma kraftfulla satsundersökare som den i
funktionsdialog. För en lista av tillgängliga funktioner se funktioner.

Objekt

Med objektdialogen kan du ändra inställningarna för alla ritobjekt. Objektdialogen kan du hitta i
utseendemenyn.

Det finns 5 flikar för varje typ av ritobjekt. Linje, Etikett, Rektangel, Ellips och Bild. För varje objekttyp kan
du definiera upp till 10 olika objekt. Alla inställningar kan ändras i denna dialog. Om du vill ta bort ett objekt,
välj objektet i objektlistan och tryck "Ta bort markerat objekt"-knappen.

Om du vill skapa objekt, kan du använda undermenyerna i ritmeny. Objekten kan sedan flyttas med musen.
Dubbelklick på ett objekt och motsvarande objektdialog öppnas.

Filinformation

Filinformationsdialogen kan nås från datadialogen. Här kan du hitta en hel del information om en datafil.
Speciellt för netcdf-, cdf- och ljudfiler kan du här titta på den interna strukturen hos en datafil.

Dump

Dumpdialogen kan nås från kurvlistedialogen. Här kan du exportera en kurva till ACII-, netcdf-, cdf-, ljud-,
binär- eller en bildfil. Varje filtyp har sina särskilda alternativ. Du kan även specificera dataintervall för
exporten.
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För ASCII-data blir filen automatiskt komprimerad, när filändelsen .gz eller .bz2 läggs till filnament.

Utseende

Med de fyra utseendedialogerna kan du påverka inställningarna hos det aktiva diagrammet. Du kan nå dessa
dialoger via "Utseende"-menyn eller genom att dubbelklicka på objektet inom diagrammet.

Diagraminställningar

Kurvdialogen låter dig välja bakgrundsfärg, kurvbakgrundsfärg, (inuti diagrammet) och intervall för de olika
axlarna. Även markörs- och baslinjeinställningar kan ändras här. Autointervallsfunktionen kan även nås från
sidoverktygslist. Om du har ett ytdiagram kan du även ändra stilinställningarna här.

Om det aktiva diagrammet är ett QWT-3D-diagram kan du välja några specialinställningar här. Diagramstilen
ändrar ytan på ett 3D-nät. Koordinat-stilen ändrar koordinaterna. Golv-stilen gör konturdiagram eller
täthetsdiagram tillgängliga på golvet med en användarspecificerat antal av isolinjer. Slutligen kan du välja en
specialfärgkarta (139 olika färgkartor finns i LabPlot som standard).

Arbetsbladsinställningar

Med arbetsbladsdialogen kan du ändra titel på ett arbetsblad och på dess tidsstämpel. Titeln och tidsstämpeln
kan även aktiveras eller deaktiveras här.

Axlar

Axeldialogen låter dig ändra inställningar för de olika axlarna. Den öppnas om du klickar på någon av
axlarna.

I det övre området har du en lista på alla axlar. Här kan du välja vilken axel, som skall ändras. För att aktivera
eller deaktivera axeln så använd kontrollknappen upptill i dialogen. Under axellistan har du olika flikar för att
ändra ett flertal axelinställningar (färg, skalstreck, rutnät m. m.).

Titel

I titeldialogen kan du ändra parametrar för titeln (etikett, storlek och typsnitt). Dialogen öppnas när du klickar
på titeln.

Förklaringstext

I förklaringstextdialogen kan du ändra parametrar för förklaringstexter (inramning, storlek och typsnitt).
Dialogen öppnas med ett dubbelklick på förklaringstexten.

Analys

Med analysdialogen kan du analysera en kurva med olika metoder. Genom att tillämpa en metod skapar du en
ny kurva, som läggs in i det aktiva diagrammet.
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Alla analysfunktioner tillåter dig att välja målet för resultatdata. Du kan lägga till resultatet till vilket befintligt
arbetsblad/kalkylblad som helst eller till ett nytt arbetsblad/kalkylblad.

De flesta analysfunktionerna kan också tillämpas i ett kalkylblad. Från vald kolumn i kalkylbladet skapas en
ny kolumn med de resulterande värdena i.

Table 5.1. Analysfunktioner i LabPlot

Namn Beskrivning Parameter Tillämpas på

Datamändsåtgärder

Om du har minst två
kurvor i det aktiva
diagrammet, kan du
genomföra åtgärder på
denna datamängd i denna
dialog. du kan addera,
subtrahera, multiplicera
och dividera datamängder
här.

två datamängder

Medelvärde

Med denna funktion kan
du medelvärdesbilda över
n punkter av en kurva.
Antalet punkter reduceras
med en faktor 1/n.

antal punkter att medelvärdesbild över allt

Komprimering

Denna funktion kan
komprimera datamängder
till färre antal punkter. Du
kan välja om du vill
summera eller
medelvärdesbilda över ett
vissta antal punkter.

summa eller medelvärde; antal punkter allt

Utjämning

Denna funktion gör
samma sak som
medelvädesbildningen,
men för varje datapunkt.
Så du kommer att få en
utjämnad kurva med
samma antal punkter.

antal punkter

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY,
X-Y-Z

Utglesa

Denna funktion reducerar
antalet punkter genom att
bara utnyttja var n-te
punkt. Antalet punkter
reduceras med en faktor
1/n.

antal punkter i följd

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Periodiska
funktioner

Denna funktion kan
användas för att reducera
en datanmängd till en
period av en funktion. Du
kan välja om du vill

summa/medelvärde; punkter per period KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY
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summera eller
medelvärdesbilda.

Säsongsmässiga

Denna funktion kan
beräkna skillnaden (eller
summan) från en period
till nästa. Perioden
specificeras av antalet
punkter i densamma.

summa/skillnad; punkter per period

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Hitta toppar

Denna funktion tillåter dig
att leta efter toppar. (även
negativa 'toppar') i en
datamängd. Känsligheten
för toppdetekteringen kan
specificeras med
parametrarna tröskel och
noggrannhet

positiva/negativa toppar; tröskel
(Y-intervall); noggrannhet (X-intervall)

X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Histogram

Med denna funktion kan
du göra histogram
utgående från en kurva.
Med detta menas att
y-intervallet delas in i n
fack och att varje
datapunkt som går in i
varje fack räknas.

använt Y-intervall; antal fack

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY,
MATRIS

Interpolation

Interpolation försöker att
hitta en jämn kurva genom
ett given mängd av
datapunkter. Du kan
använda skilda typer av
interpolation för att
åstadkomma detta : linjär,
polynom, cspline, akima.
Alla datapunkter i det
aktiva diagrammet
används vid interpolation.

interpolationstyp; intervall/antal punkter för
interpolerande funktion

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Differentiering
Denna dialog skapar en
approximativ första
derivata av en kurva.

Inga

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Integrering Denna funktion kan
användas till att numeriskt
integrera en kurva. Med
"Lägg till
kurva"-markeringen kan
du välja om du vill lägga
till den integrerade kurvan.
Med "Visa
information"-markeringen
vald, visas den kumulativa

baslinje/intervall för integration; summa
eller yta (absoluta värden)

KALKYLBLAD,
X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY
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summan i ett separat
fönster.

Regression

Regressionsfunktionen
kan användas till att
anpassa en kurva med
polynom upp till 10-de
ordningen.

vikt(modell; antal punkter/intervall för
regressionsfunktion

X-Y, X-Y-DY,
X-Y-DX-DY

Fouriertransform

Med denna funktion kan
du beräkna
fouriertransformen för en
kurva. LabPlot kan
utnyttja fftw- eller
gsl-bibliotek till detta. Du
kan välja om tranformer
eller en invers transform
skall göras.

X-värden:index/frekvens/period;
Y-värden:magnitud/fas:realdel/imaginärdel

X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Faltning/'om'faltning

Med denna funktion kan
du beräkna faltningen
mellan en kurva med en
annan. LabPlot använder
FFT från gsl till detta. Det
är även möjligt att
'om'falta en mängd.

X-värden:index/samma som signal

X-Y, X-Y-DY,
X-Y-DY-DY +
X-Y, X-Y-DY,
X-Y-DY-DY

Icke-linjär
anpassning

Med denna funktion kan
du anpassa en kurva på ett
icke-linjärt sätt. Du kan
välja mellan 12 olika
modeller eller godtycklig
användardefinierad
funktion med upp till 9
parametrar. Notera att
anpassning med
exponentiella modeller är
väldigt känsliga för
startvärdena. De
resulterande
anpassningsparametrarna
visas i bottenfältet och
byter automatiskt ut
startvärden för ytterligare
anpasssning. Resultatet
läggs till diagrammet som
en etikett.

anpasssningsfunktion; startvärden;
baslinje/intervall för anpasssning;
intervall/antalpunkter för
anpassningsfunktion

X-Y, X-Y-DY,
X-Y-DX-DY,
X-Y-DY-DY

Bildmanipulation I denna funktion kan du
manipulera matriser eller
bilddata i det aktiva
diagrammet (t. ex. ett
ytdiagram). LabPlot
använder ImageMagicks

storlek (höjd/bredd) hos resulterande bild MATRIS, BILD
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API till att omvandla
bilden med ungefär 50
olika metoder.

Arrangera

I arrangeringsdialogen kan du specificera hur diagram skall arrangeras på arbetsbladet. Med 2x2 är
diagrammen arrangerade i ett 2x2 rutnät med ett mellanrum mellan dem och arbetsbladets kanter.

Övertäckning

I övertäckningsdialogen kan du enkelt täcka över en kurva med en annan. Du måste naturligtvis ha minst två
diagram i ett arbetsblad för att kunna utnyttja detta.

QSA Workbench

LabPlot uses the Qt? Script for Applications (QSA) extension of Qt? to use scripting. To create and edit
scripts QSA includes the QSA workbench which can be used in LabPlot too. If LabPlot claims that it cannot
find some pixmaps you can set the path to the desired pixmaps with the environment variable
QSA_IMAGE_PATH. For example i use "export
QSA_IMAGE_PATH=/sw/qsa-x11-free-1.1.2/src/ide/images/" before starting LabPlot.

For more informations take a look at the Scripting Chapter

Chapter 6. Avancerade ämnen

Table of Contents

Topics
Felstaplar
TeX-etikett
Databas import/export
multipeldiagram
användning av datum- och tidformat
QWT 3D-diagram
Importerar Origin opj-filer
XML project format

Här kommer du att hitta förklaringar till avancerade ämnen.

Jag hoppas att dett kommer att hjälpa dig att förstå hur du skall använda några mer komplicerade saker i
LabPlot.

Topics

Felstaplar

Om du önskar rita diagram med felstaplar så importerar du data med import-dialog in till kalkylbaldet. Välj
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kolumn X, Y och DX, DY som du vill ha för felstaplarna. sedan bör du välja motsvarande diagram (XYDY
för Y-felstaplar, XYDXDY för X och Y-felstaplar samt XYDYDY för 2 Y-felstaplar (upptill och nertill)).

Om du använder datadialogen till att importera data direkt in i ett diagram, välj den rätta typen (x|y, x|y|dy,
x|y|dx|dy eller x|y|dy1|dy2) i "läs som" radredigeringen.

TeX-etikett

I och med version 1.5.0 stöder LabPlot uppritning av Tex-etiketter genom att använda texvc.

Om du kompilerar LabPlot på egen hand, behöver du en ocaml-kompilator. Om du använder en binärversion
av LabPlot används texvc automatiskt om den finns i din $PATH.

För att kunna utnyttja TeX-etiketter måste du kryssat i "TeX-etikett" i etikettdialogen. På detta sätt kommer
all text du matar in i textrutan att ritas med texvc. Då denna omvadling tar viss tid, kan det dröja ett tag innan
du ser att diagrammet ritas om.

Titta i "textlabel"-exemplet för att få en uppfattning hur det kan bli.

Databas import/export

LabPlot stöder läsning och skrivning i en databas genom att använda KexiDB-biblioteket. Med KexiDB kan
LabPlot läsa och skriva data i PostgreSQL, mySQL, SQListe2+3. Vid import av data välj "PostgreSQL,
mySQL, etc." i importdialogen och bläddra geom databasens struktur (tabeller och fält). Vid export av data
välj bara "DATABASE" i exportdialogen och välj önskade parametrar.

multipeldiagram

Sedan version 1.3.0 stöder LabPlot multipeldiagram på ett arbetsblad. Nya diagram kan enkelt läggas till till
ett arbetsblad genom att välja "Nytt 2D-diagram", "Nytt 3D-diagram" o. s. v. Ett nytt diagram öppnas
automatiskt när du öppnar en funktions- eller datadialog för ett diagram med annan typ än det aktiva
diagrammets. Så om du har ett 2D-diagram och väljer "Nytt 3D-diagram" läggs automatiskt ett nytt
3D-diagram.

Med "Arrangera diagram"-raden i Utseendemenyn kan du enkelt arrangera diagram på ett arbetsblad. Det
rutnätet, som används till att arrangera diagram, kan väljas med tal (som 2x2) och avståndet mellan
diagrammen och mellan diagram och arbetsbladets kanter kan ställas in med gapet.

Du kan även arrangera diagram på ett arbetsblad för hand. Genom att dra kanten hos ett diagram kan du skala
om detta som du behöver. När musen förs över kanterna på diagrammet, kommer du att se motsvarande pilar.

Ett helt diagram kan flyttas med drag och släpp när man klickar i mitten på diagrammet. Du kommer att se en
korspil när du når mitten på diagrammet.

användning av datum- och tidformat

When reading data in the data dialog you can specify the format for reading a column not only to double
(default) but also to time and date. LabPlot uses Qt?'s fromString() function to convert a column to a valid
date or time. So it really depends on that function what date and time formats are valid. It seems, when
selecting "date", the format of the column needs to be YYYY-MM-DD.
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I axeldialogen kan du välja tre olika format för skalstrecksetiketten : datum-, tid- och datumtid-format. Med
"datum" valt utvärderas värdena som dagar sendan 1.1.1970. Med "tid" valt utvärderas värdena som sekunder.
Slutgiltligen med "datumtid" valt så utvärderas värdean som sekunder sedan 1.1.1970. Du kan specificera
visat format hos skalstrecksetiketten genom att specificera en speciellt sträng på formatredigeringsraden.

Sedan 1.4.0 kan LabPlot även importera data i datumtid-format. Två olika format kan väljas. Textformatet
liknar utdata från "datum" (lokala modifieringar bör ej ställa till med problem) och ISO-formatet enligt
"YYYY-MM-DDTHH:MM:SS".

QWT 3D-diagram

Sedan version 1.4.0 kan LabPlot använda det trevliga biblioteket qwt3d till att åstadkomma mer sofistikerade
tre-dimensionella diagram. För kompatibilitetens skull finns fortfarande det enkla 3D-diagrammet kvar och
det har fortfarande några fördelar över 3D-diagram med QWT. Men jag rekommenderar användning av QWT
3D-diagram om möjligt.

QWT 3D-diagram utnyttjar OpenGL så du kan enkelt rotera, skala om och förflytta diagram med musen. I
diagraminställningsdialogen (utseendemeny) kan du definiera flera inställningar för detta tredimensionella
diagram.

Importerar Origin opj-filer

Since many people are using the well known OriginLab Origin program LabPlot includes the feature to import
Origin opj projects from versions ranging from 4.0 up to 7.5.

The opj file format is a proprietary file format so the import filter had to be developed by using reverse
engineering techniques. This is the reason why it takes a lot of work to understand and convert Origin
projects. LabPlot 1.5.0 at the moment only supports Origin worksheets.

Om någon är villig att ge lite återkoppling och/eller hjälp kommer jag att fortsätta att bygga ut detta
importfiltret.

XML project format

LabPlot 1.5.1 indroduces a new project format based on XML. With some additions it should later comply
with the OASIS standard.

The new XML format supports backward and forward compatibility and is much cleaner than the old LPL
format. This format will be used in future releases as default project format and will replace the (old) LPL
format Even though LabPlot will be able to read all old projects without any restriction.

Chapter 7. Satskontrollfunktioner

Table of Contents

standardfunktion
GSL-specialfunktion
GSL slumptalsfördelningar
Konstanter
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GSL-konstanter

LabPlot's satskontrollerare tillåter dig att använda följande funktioner:

standardfunktion

Funktion Beskrivning
acos(x) Arcus cosinus
acosh(x) Arcus cosinus hyperbolicus
asin(x) Arcus sinus
asinh(x) Arcus sinus hyperbolicus
atan(x) Arcustangens
atan2(y,x) arcustangensfunktion med två variabler
atanh(x) Arctangens hyperbolicus
beta(a,b) Beta
cbrt(x) Kubrot
ceil(x) Avkorta uppåt till heltal
chbevl(x, coef, N) Beräkna Chebyshevserier
chdtrc(df,x) Komplementerad 'Chi'-två
chdtr(df,x) 'Chi'-två fördelning
chdtri(df,y) Invers 'Chi'-två
cos(x) Cosinus
cosh(x) Cosinus hyperbolicus
cosm1(x) cos(x)-1
dawsn(x) Dawson's integral
drand() Random value between 0..1
ellie(phi,m) Ofullständig elliptisk integral (E)
ellik(phi,m) Ofullständig elliptisk integral (E)
ellpe(x) Fullständig elliptisk integral (E)
ellpk(x) Fullständig elliptisk integral (K)
exp(x) Exponential, basen e
expm1(x) exp(x)-1
expn(n,x) Exponentiell integral
fabs(x) Absolutvärde
fac(i) Fakultet
fdtrc(ia,ib,x) Komplementerad F
fdtr(ia,ib,x) F-fördelning
fdtri(ia,ib,y) Invers F-fördelning
gdtr(a,b,x) Gammafördelning
gdtrc(a,b,x) Komplementerad gamma
hyp2f1(a,b,c,x) Gauss hypergeometriska funktion
hyperg(a,b,x) 'Confluent' hypergeometrisk 1F1
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i0(x) Modifierad Bessel, ordning 0
i0e(x) Exponentiellt skalad i0
i1(x) Modifierad Bessel, ordning 1
i1e(x) Exponentiellt skalad i1
igamc(a,x) Komplementerad gammaintegral
igam(a,x) Ofullständig gammaintegral
igami(a,y0) Invers gammaintegral
incbet(aa,bb,xx) Ofullständif betaintegral
incbi(aa,bb,yy0) Invers betaintegral
iv(v,x) Modifierad Bessel, icke-heltals ordning
j0(x) Bessel, ordning 0
j1(x) Bessel, ordning 1
jn(n,x) Bessel, ordning n
jv(n,x) Bessel, icke-heltalsordning
k0(x) Mod. Bessel, 3:je slaget, ordning 0
k0e(x) Exponentiellt skalad k0
k1(x) Mod. Bessel, 3:je slaget, ordning 1
k1e(x) Exponentiellt skalad k1
kn(nn,x) Mod. Bessel, 3:je slaget, ordning n
lbeta(a,b) Naturlig logaritm av |beta|
ldexp(x,exp) multiplicera flyttal med heltalspotens av 2
log(x) Logaritm, basen e
log10(x) Logaritm, basen 10
logb(x) radixoberoende exponent
log1p(x) log(1+x)
ndtr(x) Normalfördelning
ndtri(x) Invers normalfördelning
pdtrc(k,m) Komplementerad Poisson
pdtr(k,m) Poissonfördelning
pdtri(k,y) Invers Poissonfördelning
pow(x,y) potensfunktion
psi(x) Psi (digamma) funktion
rand() Random value between 0..RAND_MAX
random() Random value between 0..RAND_MAX
rgamma(x) Reciprok Gamma
rint(x) avrunda till närmaste heltal
sin(x) Sinus
sinh(x) Sinus hyperbolicus
spence(x) Dilogaritm
sqrt(x) Kvadratrot
stdtr(k,t) Student's t-fördelning
stdtri(k,p) Invers student's t-fördelning
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struve(v,x) Struvefunktion
tan(x) Tangens
tanh(x) Tangens hyperbolicus
true_gamma(x) true_gamma(x)
y0(x) Bessel, andra slaget, ordning 0
y1(x) Bessel, andra slaget, ordning 1
yn(n,x) Bessel, andra slaget, ordning n
yv(v,x) Bessel, icke-heltalsordning
zeta(x,y) Riemann's Zeta-funktion
zetac(x) Två-argument zeta funktion

GSL-specialfunktion

För ytterligare information hänvisas till dokumentationen för GSL.

Funktion Beskrivning
gsl_log1p(x) log(1+x)
gsl_expm1(x) exp(x)-1
gsl_hypot(x,y) sqrt{x^2 + y^2}
gsl_acosh(x) arccosh(x)
gsl_asinh(x) arcsinh(x)
gsl_atanh(x) arctanh(x)
airy_Ai(x) Airy funktion Ai(x)
airy_Bi(x) Airy funktion Bi(x)
airy_Ais(x) skalad version Airy funktionen S_A(x) Ai(x)
airy_Bis(x) skalad version af Airy funktionen S_B(x) Bi(x)
airy_Aid(x) Airyfunktion derivata Ai'(x)
airy_Bid(x) Airy funktion derivata Bi'(x)
airy_Aids(x) derivata av den skalade Airy funktionen S_A(x) Ai(x)
airy_Bids(x) derivata av den skalade Airy funktionen S_B(x) Bi(x)
airy_0_Ai(s) s-te nollstället hos Airy funktionen Ai(x)
airy_0_Bi(s) s-te nollstället hos Airy funktionen Bi(x)
airy_0_Aid(s) s-te nollstället hos Airy funktionen derivata Ai'(x)
airy_0_Bid(s) s-te nollstället hos Airy funktionen derivata Bi'(x)
bessel_J0(x) reguljär cylindrisk Besselfunktion av nollte ordningen, J_0(x)
bessel_J1(x) reguljär cylindrisk Besselfunktion av första ordningen, J_1(x)
bessel_Jn(n,x) reguljär cylindrisk Besselfunktion av ordningen n, J_n(x)
bessel_Y0(x) irreguljär cylindrisk Besselfunktion av nollte ordningen, Y_0(x)
bessel_Y1(x) irreguljär cylindrisk Besselfunktion av första ordningen, Y_1(x)
bessel_Yn(n,x) irreguljär cylindrisk Besselfunktion av ordningen n, Y_n(x)
bessel_I0(x) reguljär modifierad cylindrisk Besselfunktion av nollte ordningen, I_0(x)
bessel_I1(x) reguljär modifierad cylindrisk Besselfunktion av första ordningen, I_1(x)
bessel_In(n,x) reguljär modifierad cylindrisk Besselfunktion av ordningen n, I_n(x)
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bessel_I0s(x) skalad reguljär modifierad cylindrisk Besselfunktion av nollte ordningen, exp
(-|x|) I_0(x)

bessel_II1s(x) skalad reguljär modifierad cylindrisk Besselfunktion av första ordningen,
exp(-|x|) I_1(x)

bessel_Ins(n,x) skalad reguljär modifierad cylindrisk Besselfunktion av ordningen n, exp(-|x|)
I_n(x)

bessel_K0(x) irreguljär modifierad cylindriskl Besselfunktion av nollte ordningen, K_0(x)
bessel_K1(x) irreguljär modifierad cylindriskl Besselfunktion av första ordningen, K_1(x)
bessel_Kn(n,x) irreguljär modifierad cylindriskl Besselfunktion av ordningen n, K_n(x)

bessel_KK0s(x) skalad irreguljär modifierad cylindriskl Besselfunktion av nollte ordningen, exp
(x) K_0(x)

bessel_KK1s(x) skalad irreguljär modifierad cylindriskl Besselfunktion av första ordningen,
exp(x) K_1(x)

bessel_Kns(n,x) skalad irreguljär modifierad cylindriskl Besselfunktion av ordningen n, exp(x)
K_n(x)

bessel_j0(x) reguljär sfärisk Besselfunktion av nollte ordningen, j_0(x)
bessel_j1(x) reguljär sfärisk Besselfunktion av första ordningen, j_1(x)
bessel_j2(x) reguljär sfärisk Besselfunktion av andra ordningen, j_2(x)
bessel_jl(l,x) reguljär sfärisk Besselfunktion av ordningen l, j_l(x)
bessel_y0(x) irreguljär sfärisk Besselfunktion av nollte ordningen, y_0(x)
bessel_y1(x) irreguljär sfärisk Besselfunktion av första ordningen, y_1(x)
bessel_y2(x) irreguljär sfärisk Besselfunktion av andra ordningen, y_2(x)
bessel_yl(l,x) irreguljär sfärisk Besselfunktion av ordningen l, y_l(x)
bessel_i0s(x) skalad reguljär sfärisk Besselfunktion av nollte ordningen, exp(-|x|) i_0(x)
bessel_i1s(x) skalad reguljär sfärisk Besselfunktion av första ordningen, exp(-|x|) i_1(x)
bessel_i2s(x) skalad reguljär sfärisk Besselfunktion av andra ordningen, exp(-|x|) i_2(x)
bessel_ils(l,x) skalad reguljär sfärisk Besselfunktion av ordningen l, exp(-|x|) i_l(x)

bessel_k0s(x) skalad irreguljär modifierad sfärisk Besselfunktion av nollte ordningen, exp(x)
k_0(x)

bessel_k1s(x) skalad irreguljär modifierad sfärisk Besselfunktion av första ordningen, exp(x)
k_1(x)

bessel_k2s(x) skalad irreguljär modifierad sfärisk Besselfunktion av andra ordningen, exp(x)
k_2(x)

bessel_kls(l,x) skalad irreguljär modifierad sfärisk Besselfunktion av ordningen l, exp(x)
k_l(x)

bessel_Jnu(nu,x) reguljär cylindrisk Besselfunktion av fraktionalordningen nu, J_\nu(x)
bessel_Ynu(nu,x) irreguljär cylindrisk Besselfunktion av fraktionalordningen nu, Y_\nu(x)
bessel_Inu(nu,x) reguljär modifierad Besselfunktion av fraktionalordningen nu, I_\nu(x)

bessel_Inus(nu,x) skalad reguljär modifierad Besselfunktion av fraktionalordningen nu, exp(-|x|)
I_\nu(x)

bessel_Knu(nu,x) irreguljär modifierad Besselfunktion av fraktionalordningen nu, K_\nu(x)

bessel_lnKnu(nu,x) logaritm av den irreguljära modifierade Besselfunktion av fraktionalordningen
nu,ln(K_\nu(x))

bessel_Knus(nu,x)

Handbok för LabPlot

GSL-specialfunktion 33



skalad irreguljär modifierad Besselfunktion av fraktionalordningen nu, exp(|x|)
K_\nu(x)

bessel_0_J0(s) s-te positiva nollstället hos Besselfunktionen J_0(x)
bessel_0_J1(s) s-te positiva nollstället hos Besselfunktionen J_1(x)
bessel_0_Jnu(nu,s) s-te positiva nollstället hos Besselfunktionen J_nu(x)
clausen(x) Clausenintegral Cl_2(x)

hydrogenicR_1(Z,R) lägsta ordningens normaliserade 'hydrogenic bound state radial'-vågfunktion
R_1 := 2Z \sqrt{Z} \exp(-Z r)

hydrogenicR(n,l,Z,R) n-te normaliserade 'hydrogenic bound state radial'-vågfunktionen
dawson(x) Dawson's integral
debye_1(x) första ordningens Debye-funktion D_1(x) = (1/x) \int_0^x dt (t/(e^t - 1))
debye_2(x) andra ordningens Debye-funktion D_2(x) = (2/x^2) \int_0^x dt (t^2/(e^t - 1))
debye_3(x) tredje ordningens Debye-funktion D_3(x) = (3/x^3) \int_0^x dt (t^3/(e^t - 1))
debye_4(x) fjärde ordningens Debye-funktion D_4(x) = (4/x^4) \int_0^x dt (t^4/(e^t - 1))
dilog(x) dilogaritm
ellint_Kc(k) fullständig elliptisk integral K(k)
ellint_Ec(k) fullständig elliptisk integral E(k)
ellint_F(phi,k) ofullständig elliptisk integral F(phi,k)
ellint_E(phi,k) ofullständig elliptisk integral E(phi,k)
ellint_P(phi,k,n) ofullständig elliptisk integral P(phi,k,n)
ellint_D(phi,k,n) ofullständig elliptisk integral D(phi,k,n)
ellint_RC(x,y) ofullständig elliptisk integral RC(x,y)
ellint_RD(x,y,z) ofullständig elliptisk integral RD(x,y,z)
ellint_RF(x,y,z) ofullständig elliptisk integral RF(x,y,z)
ellint_RJ(x,y,z) ofullständig elliptisk integral RJ(x,y,z,p)
gsl_erf(x) error function erf(x) = (2/\sqrt(\pi)) \int_0^x dt \exp(-t^2)

gsl_erfc(x) komplementär error function erfc(x) = 1 - erf(x) = (2/\sqrt(\pi)) \int_x^\infty
\exp(-t^2)

log_erfc(x) logaritm av den komplimentära error function \log(\erfc(x))
erf_Z(x) Gaussisk sannolikhetsfunktion Z(x) = (1/(2\pi)) \exp(-x^2/2)

erf_Q(x) övre svans av den Gaussiska sannolikhetsfunktion Q(x) = (1/(2\pi))
\int_x^\infty dt \exp(-t^2/2)

gsl_exp(x) exponentialfunktion
exprel(x) (exp(x)-1)/x med en algoritm, som är noggrann för små x
exprel_2(x) 2(exp(x)-1-x)/x^2 med en algoritm, som är noggrann för små x

exprel_n(n,x) n-relativ exponential, som är den n-te generalisationen av funktionerna
`gsl_sf_exprel'

exp_int_E1(x) exponentialintegral E_1(x), E_1(x) := Re \int_1^\infty dt \exp(-xt)/t

exp_int_E2(x) andra ordningens exponentialintegral E_2(x), E_2(x) := \Re \int_1^\infty dt
\exp(-xt)/t^2

exp_int_Ei(x) exponentialintegral E_i(x), Ei(x) := PV(\int_{-x}^\infty dt \exp(-t)/t)
shi(x) Shi(x) = \int_0^x dt sinh(t)/t
chi(x) integral Chi(x) := Re[ gamma_E + log(x) + \int_0^x dt (cosh[t]-1)/t]
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expint_3(x) exponentialintegral Ei_3(x) = \int_0^x dt exp(-t^3) for x >= 0
si(x) Sinusintegral Si(x) = \int_0^x dt sin(t)/t
ci(x) Cosinusintegral Ci(x) = -\int_x^\infty dt cos(t)/t för x > 0
atanint(x) Arctangensintegral AtanInt(x) = \int_0^x dt arctan(t)/t

fermi_dirac_m1(x) fullständig Fermi-Dirac-integral med ett index på -1, F_{-1}(x) = e^x / (1 +
e^x)

fermi_dirac_0(x) fullständig Fermi-Dirac-integral med ett index på 0, F_0(x) = \ln(1 + e^x)

fermi_dirac_1(x) fullständig Fermi-Dirac-integral med ett index på 1, F_1(x) = \int_0^\infty dt (t
/(\exp(t-x)+1))

fermi_dirac_2(x) fullständig Fermi-Dirac-integral med ett index på 2, F_2(x) = (1/2) \int_0^\infty
dt (t^2 /(\exp(t-x)+1))

fermi_dirac_int(j,x) fullständig Fermi-Dirac-integral med ett index på j, F_j(x) = (1/Gamma(j+1))
\int_0^\infty dt (t^j /(exp(t-x)+1))

fermi_dirac_mhalf(x) fullständig Fermi-Dirac-integral F_{-1/2}(x)
fermi_dirac_half(x) fullständig Fermi-Dirac-integral F_{1/2}(x)
fermi_dirac_3half(x) Fullständig Fermi-Dirac-integral F_{3/2}(x)

fermi_dirac_inc_0(x,b) ofullständig Fermi-Dirac-integral med ett index på noll, F_0(x,b) = \ln(1 +
e^{b-x}) - (b-x)

gamma(x) Gammafunktion
lngamma(x) logaritm av Gammafunktionen
gammastar(x) 'regulated' Gammafunktion \Gamma^*(x) for x > 0

gammainv(x) reciprok av gammafunktionen, 1/Gamma(x) med hjälp av den reella Lanczos
metoden.

taylorcoeff(n,x) Taylorkoefficient x^n / n! for x >= 0
fact(n) n-fakultet
doublefact(n) dubbelfakultet n!! = n(n-2)(n-4)...
lnfact(n) Logaritm av n-fakultet, log(n!)
lndoublefact(n) logaritm av dubbel n-fakultet, log(n!!)
choose(n,m) 'combinatorial facto'r `n choose m' = n!/(m!(n-m)!)
lnchoose(n,m) logaritm av 'n choose m'
poch(a,x) Pochhammersymbol (a)_x := \Gamma(a + x)/\Gamma(x)
lnpoch(a,x) logaritm av Pochhammersymbolen (a)_x := \Gamma(a + x)/\Gamma(x)

pochrel(a,x) relativa Pochhammersymbol ((a,x) - 1)/x där (a,x) = (a)_x := \Gamma(a +
x)/\Gamma(a)

gamma_inc_Q(a,x) Normaliserad ofullständig Gammafunktion P(a,x) = 1/Gamma(a) \int_x\infty dt
t^{a-1} exp(-t) for a > 0, x >= 0

gamma_inc_P(a,x) Komplementär normaliserad ofullständig Gamma Function P(a,x) =
1/Gamma(a) \int_0^x dt t^{a-1} exp(-t) för a > 0, x >= 0

gsl_beta(a,b) Betafunktion, B(a,b) = Gamma(a) Gamma(b)/Gamma(a+b) för a > 0, b > 0
lnbeta(a,b) logaritm av Betafunktionen, log(B(a,b)) för a > 0, b > 0
betainc(a,b,x) normaliserad ofullständig Betafunktion B_x(a,b)/B(a,b) för a > 0, b > 0
gegenpoly_1(lambda,x) Gegenbauer polynom C^{lambda}_1(x)
gegenpoly_2(lambda,x) Gegenbauer polynom C^{lambda}_2(x)
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gegenpoly_3(lambda,x) Gegenbauer polynom C^{lambda}_3(x)
gegenpoly_n(n,lambda,x) Gegenbauer polynom C^{lambda}_n(x)
hyperg_0F1(c,x) hypergeometrisk funktion 0F1(c,x)

hyperg_1F1i(m,n,x) 'confluent' hypergeometrisk funktion 1F1(m,n,x) = M(m,n,x) för heltaliga
parametrar m, n

hyperg_1F1(a,b,x) 'confluent' hypergeometrisk funktion 1F1(m,n,x) = M(m,n,x) för generella
parametrar a, b

hyperg_Ui(m,n,x) 'confluent' hypergeometrisk funktion U(m,n,x) för heltaliga parametrar m, n
hyperg_U(a,b,x) 'confluent' hypergeometrisk funktion U(a,b,x)
hyperg_2F1(a,b,c,x) Gauss hypergeometriska funktion 2F1(a,b,c,x)

hyperg_2F1c(ar,ai,c,x) Gauss hypergeometriska funktion 2F1(a_R + i a_I, a_R - i a_I, c, x) med
komplexa parametrar

hyperg_2F1r(ar,ai,c,x) Renormaliserad Gauss hypergeometriska funktion 2F1(a,b,c,x) / Gamma(c)

hyperg_2F1cr(ar,ai,c,x) Renormaliserad Gauss hypergeometriska funktion 2F1(a_R + i a_I, a_R - i a_I,
c, x) / Gamma(c)

hyperg_2F0(a,b,x) Hypergeometrisk function 2F0(a,b,x)
laguerre_1(a,x) Generaliserat Laguerre polynom L^a_1(x)
laguerre_2(a,x) Generaliserat Laguerre polynom L^a_2(x)
laguerre_3(a,x) Generaliserat Laguerre polynom L^a_3(x)
lambert_W0(x) Huvudgren av Lambert W-funktionen, W_0(x)
lambert_Wm1(x) Sekundära realvärdesgrenen av Lambert W-funktion, W_{-1}(x)
legendre_P1(x) Legendrepolynom P_1(x)
legendre_P2(x) Legendrepolynom P_2(x)
legendre_P3(x) Legendrepolynom P_3(x)
legendre_Pl(l,x) Legendrepolynom P_l(x)
legendre_Q0(x) Legendrepolynom Q_0(x)
legendre_Q1(x) Legendrepolynom Q_1(x)
legendre_Ql(l,x) Legendrepolynom Q_l(x)
legendre_Plm(l,m,x) associerade Legendrepolynom P_l^m(x)

legendre_sphPlm(l,m,x) Normaliserat associerat Legendrepolynom $\sqrt{(2l+1)/(4\pi)}
\sqrt{(l-m)!/(l+m)!} P_l^m(x)$ passande för användning i 'spherical harmonics'

conicalP_half(lambda,x) Irreguljär sfärisk-konisk funktion P^{1/2}_{-1/2 + i \lambda}(x) för x > -1
conicalP_mhalf(lambda,x) reguljär sfärisk-konisk funktion P^{-1/2}_{-1/2 + i \lambda}(x) för x > -1
conicalP_0(lambda,x) Konisk funktion P^0_{-1/2 + i \lambda}(x) för x > -1v
conicalP_1(lambda,x) Konisk funktion P^1_{-1/2 + i \lambda}(x) för x > -1

conicalP_sphreg(l,lambda,x) Reguljär sfärisk-konisk funktion P^{-1/2-l}_{-1/2 + i \lambda}(x) för x > -1, l>= -1

conicalP_cylreg(l,lambda,x) Reguljär cylindrisk-konisk funktion P^{-m}_{-1/2 + i \lambda}(x) för x > -1,
m >= -1

legendre_H3d_0(lambda,eta)
nollte radial-egenfunktionen hos Laplace på den 3-dimensionella hyperboliska
rymden, L^{H3d}_0(lambda,eta) := sin(lambda eta)/(lambda sinh(eta)) för eta
>= 0

legendre_H3d_1(lambda,eta)
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Nollte radial-egenfunktionen hos Laplace på den 3-dimensionella hyperboliska
rymden, L^{H3d}_1(lambda,eta) := 1/sqrt{lambda^2 + 1} sin(lambda
eta)/(lambda sinh(eta)) (coth(eta) - lambda cot(lambda eta)) för eta >= 0

legendre_H3d(l,lambda,eta) L:te radial-egenfunktionen av Laplace på den 3-dimensionella hyperboliska
rymden eta >= 0, l >= 0

gsl_log(x) Logaritm of X
loga(x) Logaritm av magnituden of X, log(|x|)

logp(x) log(1 + x) för x > -1 med användning av en algoritm, som är noggrann för små
x

logm(x) log(1 + x) - x för x > -1 med användning av en algoritm, som är noggrann för
små x

gsl_pow(x,n) Potens x^n för heltaliga n
psii(n) digamma-funktion psi(n) för positiva heltal n
psi(x) digamma-funktion psi(n) för generalla x
psiy(y) Realdel av digamma-funktionen på linjen 1+i y, Re[psi(1 + i y)]
ps1i(n) Trigamma-funktion psi'(n) för positiva heltal n
ps_n(m,x) polygamma-funktion psi^{(m)}(x) för m >= 0, x > 0
synchrotron_1(x) första synchrotron-funktionen x \int_x^\infty dt K_{5/3}(t) för x >= 0
synchrotron_2(x) andra synchrotron-funktionen x K_{2/3}(x) för x >= 0
transport_2(x) transportfunktion J(2,x)
transport_3(x) transportfunktion J(3,x)
transport_4(x) transportfunktion J(4,x)
transport_5(x) transportfunktion J(5,x)
hypot(x,y) hypotenusafunktionen \sqrt{x^2 + y^2}
sinc(x) sinc(x) = sin(pi x) / (pi x)
lnsinh(x) log(sinh(x)) för x > 0
lncosh(x) log(cosh(x))
zetai(n) Riemann's zetafunktion zeta(n) för heltaliga N
gsl_zeta(s) Riemann's zetafunktion zeta(s) för godtyckliga s
hzeta(s,q) Hurwitz zeta-funktion zeta(s,q) för s > 1, q > 0
etai(n) eta funktionen eta(n) för heltals n
eta(s) eta funktionen eta(s) för godtyckligt s

GSL slumptalsfördelningar

För ytterligare information hänvisas till dokumentationen för GSL.

Funktion Beskrivning

gaussian(x,sigma) sannoliktäthetsfunktion p(x) vid X för en Gaussisk fördelning
med standardavvikelsen SIGMA

ugaussian(x) enhets-Gaussisk fördelning. Den är ekvivalent med funktionen
ovan med standardavvikelsen av ett, SIGMA = 1

gaussian_tail(x,a,sigma) sannoliktäthetsfunktion p(x) för svansen i en Gaussisk
fördelning med standardavvikelsen SIGMA och undre gräns A
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ugaussian_tail(x,a)
svansen hos en enhets-Gaussisk fördelning. Den är ekvivalent
med funktionen ovan med standardavvikelsen av ett, SIGMA =
1

bivariate_gaussian(x,y,sigma_x,sigma_y,rho)
sannoliktäthetsfunktion p(x) vid (X,Y) för en 'bivariate'
gaussisk fördelning med standardavvikelsen SIGMA_X,
SIGMA_Y och korrelationskoefficient RHO

exponential(x,mu) sannoliktäthetsfunktion p(x) vid X för en exponentiell
fördelning med medelvärdet MU

laplace(x,a) sannoliktäthetsfunktion p(x) vid X för en Laplace-fördelning
med medelvärdet A

exppow(x,a,b) sannoliktäthetsfunktion p(x) vid X för en exponentiell
potensfördelning med skalningsparameter A och exponent B

cauchy(x,a) sannoliktäthetsfunktion p(x) vid X för en Cauchy-fördelning
med skalningsparameter A

rayleigh(x,sigma) sannoliktäthetsfunktion p(x) vid X för en Rayleigh-fördelning
med skalningsparameter SIGMA

rayleigh_tail(x,a,sigma)
sannoliktäthetsfunktion p(x) vid X för en Rayleigh
svansfördelning med skalningsparameter SIGMA och undre
gräns A

landau(x) sannoliktäthetsfunktion p(x) vid X för Landau-fördelningen

gamma_pdf(x,a,b) sannoliktäthetsfunktion p(x) vid X för en gammafördelning
med parametrarna A och B

flat(x,a,b) sannoliktäthetsfunktion p(x) vid X för en likformig fördelning
från A till B

lognormal(x,zeta,sigma) sannoliktäthetsfunktion p(x) vid X för en lognormal fördelning
med parametrar ZETA och SIGMA

chisq(x,nu) sannoliktäthetsfunktion p(x) vid X för en chi-två fördelning
med NU frihetsgrader

fdist(x,nu1,nu2) sannoliktäthetsfunktion p(x) vid X för en F-fördelning med
NU1 och NU2 frihetsgrader

tdist(x,nu) sannoliktäthetsfunktion p(x) vid X för en t-fördelning med NU
frihetsgrader

beta_pdf(x,a,b) sannoliktäthetsfunktion p(x) vid X för en betafördelning med
parametrar A och B

logistic(x,a) sannoliktäthetsfunktion p(x) vid X för en logistisk fördelning
med skalningsparameter A

pareto(x,a,b) sannoliktäthetsfunktion p(x) vid X för en Pareto-fördelning
med exponent A och skala B

weibull(x,a,b) sannoliktäthetsfunktion p(x) vid X för en Weibull-fördelning
med skala A och exponent B

gumbel1(x,a,b) sannoliktäthetsfunktion p(x) vid X för en Typ-1
Gumbel-fördelning med parametrar A och B

gumbel2(x,a,b) sannoliktäthetsfunktion p(x) vid X för en Typ-2
Gumbel-fördelning med parametrar A och B

poisson(k,mu) sannolikhet p(k) för att erhålla K från en Poisson-fördelning
med medelvärde mu
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bernoulli(k,p) sannolikhet p(k) för att erhålla K från en Poisson-fördelning
med sannolikhetsparameter P

binomial(k,p,n) sannolikhet p(k) för att erhålla K från en binomialfördelning
med parametrar P och N

negative_binomial(k,p,n) sannolikhet p(k) för att erhålla K från en negativ
binomialfördelning med parametrar P och N

pascal(k,p,n) sannolikhet p(k) för att erhålla K från en Pascal-fördelning
med parametrar P och N

geometric(k,p) sannolikhet p(k) för att erhålla K från en geometrisk fördelning
med sannolikhetsparameter P

hypergeometric(k,n1,n2,t) sannolikhet p(k) för att erhålla K från en hypergeometrisk
fördelning med parametrar N1, N2, N3

logarithmic(k,p) sannolikhet p(k) för att erhålla K från en logaritmisk fördelning
med sannolikhetsparameter P

Konstanter

Konstant Beskrivning
PI1 1/pi
PI2 2/pi
PISQRT2 2/sqrt(pi)
E e
LN2 log_e 2
LN10 log_e 10
LOG2E log_2 e
LOG10E log_10 e
PI pi
PI_2 pi/2
PI_4 pi/4
SQRT2 sqrt(2)
SQRT1_2 1/sqrt(2)

GSL-konstanter

För ytterligare information om dessa konstanter hänvisas till GSL-dokumentationen.

Konstant Beskrivning
c Ljushastiget i vakuum
mu0 Permeabilitet i fri rymd
e0 Permittivitet i fri rymd
Na Avogadro's tal
F Faradaykonstant
k Boltzmanns konstant
R0 Universella gaskonstanten
V0 Standardgasvolymen
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Gauss Magnetfältet på 1 Gauss
mu Längden av 1 mikron
ha Ytan av ett hektar
mph Hastigheten 1 engelsk mil per timme
kmh Hastigheten 1 kilometer per timme
au Längden av 1 astronomusk enhet (menande jord-solavståndet)
G Gravitationskonstanten
ly Avståndet 1 ljusår
pc Avståndet 1 parsec
g Standardgravitationskonstanten på jordytan
ms Solens massa
e Elektronladdningen
eV Energin 1 elektronvolt
amu 'Unified' atom-massan
me Elektronens massa
mmu Muonmassan
mp Protonmassan
mn Neutronmassan
alpha Elektromagnetiska finstrukturkonstanten
Ry Rydbergkonstanten
a0 Bohr-radie
A Längden av 1 ångstrom
barn Ytan av 1 barn
muB Bohr-magnetonen
muN Nukleära magnetonen
mue Magnetiska momentet hos elektronen
mup Magnetiska momentet hos protonen
min Antal sekunder på 1 minut
h Antal sekunder på en timme
d Antal sekunder på en dag
vecka Antal sekunder på en vecka
in Längden av 1 engelsk tum
ft Längden av 1 engelsk fot
yard Längden av 1 yard
mile Längden av 1 engelsk mil
mill Längden av 1 mill (en tusendels engelsk tum)
nmile Längden av 1 nautisk mil (sjömil)
fathom Längden av 1 fathom
knop Hastigheten 1 knop
pt Längden av 1 skrivar-punkt (1/72 engelsk tum)
texpt Längden av 1 TeX-punkt (1/72,27 egelska tum)
tunnland Ytan av 1 tunnland
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ltr Volymen av 1 liter
us_gallon Volymen av 1 US gallon
can_gallon Volymen av 1 kandensisk gallon
uk_gallon Volymen av 1 UK gallon
quart Volymen av 1 quart
pint Volymen av 1 pint
pound Massan hos 1 pund
ounce Massan hos 1 ounce
ton Massan hos 1 ton
mton Massan hos 1 metriskt ton (1000 kg)
uk_ton Massan hos 1 UK ton
troy_ounce Massan hos 1 'troy ounce'
karat massan hos 1 karat
gram_force Kraften hos vikten 1 gram
pound_force Kraften hos vikten 1 pund
kilepound_force kraften hos vikten 1 kilopound
poundal Kraften hos 1 poundal
cal Energin hos 1 kalori
btu Energin hos 1 British Thermal Unit
therm Energin hos 1 Therm
hp Effekten 1 hästkraft
bar Trycket hos 1 bar
atm Trycket 1 standardatmosfär
torr Trycket hos 1 torr
mhg Trycket hos 1 meter kvicksilver
inhg Trycket hos 1 engelsk tum med kvicksilver
inh2o Trycket hos 1 engelsk tum med vatten
psi Trycket hos 1 pound per kvadrattum
poise Dynamiska viskositeten 1 poise
stokes Kinematiska viskositeten 1 stokes
stilb Luminansen 1 stilb
lumen Ljusflödet hos 1 lumen
lux Illuminansen 1 lux
phot Illuminansen 1 phot
ftcandle Illuminansen 1 footcandela
lambert Luminansen 1 lambert
ftlambert luminansen 1 footlambert
curie Aktiviteten 1 curie
roentgen Exponeringen för 1 röntgen
rad Absorberad dos 1 rad
Följande konstanter är samma konstanter som i cgs-systemet:
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Konstant Beskrivning
c_cgs
G_cgs
h_cgs
hbar_cgs
mu0_cgs
au_cgs
ly_cgs
pc_cgs
g_cgs
eV_cgs
me_cgs
mmu_cgs
mp_cgs
mn_cgs
Ry_cgs
k_cgs
muB_cgs
muN_cgs
mue_cgs
mup_cgs
R0_cgs
V0_cgs
in_cgs
ft_cgs
yard_cgs
mile_cgs
nile_cgs
fathom_cgs
mil_cgs
pt_cgs
texpt_cgs
mu_cgs
A_cgs
ha_cgs
acre_cgs
barn_cgs
ltr_cgs
us_gallon-cgs
quart_cgs
pint_cgs
cup_cgs
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fluid_ouncs_cgs
tablespoon_cgs
teaspoon_cgs
can_gallon_cgs
uk_gallon_cgs
mph_cgs
kmh_cgs
knot_cgs
pound_cgs
ouncs_cgs
ton_cgs
mton_cgs
uk_ton_cgs
troy_ounce_cgs
carat_cgs
amu_cgs
gram_cgs
pound_force_cgs
kilopound_force_cgs
poundal_cgs
cal_cgs
btu_cgs
therm_cgs
hp_cgs
bar_cgs
atm_cgs
torr_cgs
mhg_cgs
inhg_cgs
inh2o_cgs
psi_cgs
poise_cgs
stokes_cgs
F_cgs
e_cgs
G_cgs
stilb_cgs
lumen_cgs
lux_cgs
phot_cgs
ftcandle_cgs
lambert_cgs
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ftlambert_cgs
curie_cgs
roentgen_cgs
rad_cgs
sm_cgs
a0_cgs
e0_cgs

Chapter 8. Skriptning

Table of Contents

QSA
Using Scripts
Specials

This chapter explains the scripting interface of LabPlot that can help you to automate your work. With the use
of the scripting interface you can get very productive and simplify your work when doing the same things
often. With the knowledge of this interface you are able to completely control LabPlot remotely .

QSA

LabPlot uses Qt? Script for Applications (QSA) developed by Trolltech, Inc. It is released under two different
licenses - one commercial (that costs an arm and a leg) and the other GPL (free for download). The GPL
version has some restrictions that are applicable to the case of a commercially developed application.

Of course LabPlot needs to be build with QSA support. For KDE 3 (based on Qt? 3) you need version 1.1.X
of QSA.

Using Scripts

Scripts are small files that contain instructions to be executed. Since LabPlot can interpret such scripts it can
be automated using this. Scripts can be created and edited with your favorite text editor or by using the QSA
Workbench (Can be found in the LabPlot menu under "Script->QSA Workbench..."). If the icons in the
Workbench are missing check out the  Workbench Chapter.

To execute a script you can call LabPlot script.qs from the commandline or drag and drop a script on
the desktop into LabPlot. You can also use the dialog "Script->Open Script" in LabPlot to execute a script.

LabPlot is divided into a bunch of classes. For most scripting needs, you need to know only a few of them.
For every operation you just call the corresponding function on the LabPlot classes. All available functions
can be found in the classes reference at
http://cvs.sourceforge.net/viewcvs.py/*checkout*/labplot/doc/html/hierarchy.html.

All MainWin functions can be called directly. Let start with

importData("sample.dat");

This simply imports the data file "sample.dat" into a Spreadsheet in LabPlot. You can see it in the screenshot.
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If you now want to work with the Spreadsheet you have to call the corresponding Spreadsheet function. Let's
say we want to make a 2D Plot

importData("sample.dat");
s = activeSpreadsheet();
s.plot2DSimple();

The result is

Now we want to work on the Plot. We have to get the Worksheet and the active Plot of it. The script looks
like that:

importData("sample.dat");
s = activeSpreadsheet();
s.plot2DSimple();
w = activeWorksheet();
p = w.get2DPlot(w.API());
p.setBackground("green");
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w.redraw();

With the result that we have a green background

A complete script that imports data and changes some settings before saving the result as EPS would look like
this:

importData("sample-data/sin.dat");

s = activeSpreadsheet();
s.plot2DSimple();

w = activeWorksheet();
p = w.get2DPlot(w.API());

p.setBackground("green");
p.setGraphBackground("lightblue");

r = p.ActRange(0);
r.setRange(250,750);
r = p.ActRange(1);
r.setRange(-2,2);

l = p.getLegend();
l.setPosition(.5,.4);

t = p.Title();
t.setTitle("example title");
t.setRotation(10);

a = p.getAxis(0);
a.enableMajorGrid();
ll = a.getLabel();
ll.setTitle("different x axis");
font = new Font("SanSerif");
a.setTickLabelFont(font);

p.setMarksEnabled();
mark = p.markX();
mark.setRange(450,550);
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p.setRegionEnabled();
p.setRegion(350,650);

// w.redraw();

exportEPS("export.eps");
exit();

The used functions should be quite self-explanatory. the resulting EPS then looks like that

This is basically all you need to know about writing scripts. More examples can be found in the directory
examples/scripts/ of the source distribution or in the data directory of LabPlot.

Specials

For a detailed description of the QSA syntax check out the QSA documentation. All enumerations available in
LabPlot can also be used in Scripts, check out the global script labplot.qs.

With QSA it is also possible to use dialogs to enter filenames, etc. . The following example uses a dialog to
enter a data file name:

d = new ImportDialog();

var filename = FileDialog.getOpenFileName( "*.dat" );
if (filename) {
        d.setFilename(filename);
        d.Apply();
}

Chapter 9. Exempel

I detta kapitel finner du förklaringar till LabPlots exempelprojekt. Du hittar alla exemplen under
Hjälp->Exempel såvida inte annat anges
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Table 9.1. Exempelprojet för LabPlot

Skärmdump Namn Beskrivning

axeletikett
Detta exempel visar hur man använder skilda
axeletiketter. Den visade funktionen är fylld till
baslinjen.

rydbergspektra
Detta exempel visar ett Rydbergspektra mätt med
ljusexitering av metastabilt helium i en
magneto-optisk fälla.

log-axelskala Detta exempel använder logaritmiska axelskalor
med anpassad skalsstrecksetikett

ljuddata Detta exempel visar hur data läses från en ljudfil

markör Detta exempel visar användning av markör
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TeX-etikett Detta exempel använder TeX-etikett

analys

Detta exempel visar skillnaden mellan de tre
analysfunktionerna utglesa, medelvärdesbilda och
utjämna. Här kan du se skilda stilar och symboler
för visade data.

enkel fft Detta exempel visar hur en enkel fouriertransform
kan se ut.

histogram Detta exempel visar ett histogram av en periodisk
funktion.
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icke-linjär anpassning Detta exempel visar en icke-linjär anpassning av
data i ett specificerat intervall.

exponentiell
anpassning

Detta exempel visar hur en exponentiell anpassning
av data bör se ut.

logaritmisk anpassning Detta exempel visar en exponentiell anpassning
inuti ett logartimiskt diagram.

yta

Detta exempel visar ett enkelt ytdiagram med
täthets- och konturdiagram av en använd definierad
funktion. Färgpaletten är vald för att snyggt visa
funktionsvärdena.

ytdiagramstil Detta exempel visar samma datamängd, som i
ytdiagrammet, men i andra stilar.
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3D Detta exempel visar ett enkelt 3-dimensionellt
diagram skapad från en funktion.

ritobjekt Detta exempel visar användningen av ritobjekt i
LabPlot.

bilder Detta exempel visar ett ytdiagram skapat från en
bildfil (uxm.xpm).

cirkeldiagram Detta exempel visar ett enkelt cirkeldiagram skapat
från två-dimensionella data

stabeldiagram Detta exempel visar användningen av stapelstilen
för x- och y-intervall.
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multipla diagram

Detta exempel visar användningen av multipla
diagram per arbetsblad. Här kan du se fyra skilda
typer av diagram arrangerade 2x2 med ett
mellanrum på 0,05.

qwt 3D-diagram

Detta exempel visar användningen av ett qwt
3D-diagram. Detta exempel använder anpassad
färgkarta och "flooriso"-stil till att göra konturlinjer
på botten.

ett annat ytdiagram
Detta visar ett annat exempel på ytdiagram. Detta
exempel visar även hur logaritmiska axelskalor kan
används.

polärdiagram Detta exempel visar ett enkelt polärt diagram skapat
från funktioner

triangeldiagram Detta exempel visar ett triangeldiagram skapat med
lite data
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sfi (endast på
neladdningsplatsen)

Detta exempel introducerar övertäckningsdiagram
genom att visa ett selektivt fältjonisationsspektra
övertäckt med fältrampen.

Chapter 10. Kända fel
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Kända fel

Här hittar du en lista på kända fel. För en mer detaljerad list hänvisas till TODO-filen i LabPlot-paketet.

1. pstoedit arbetar inte korrekt ibland.
2. LabPlot kraschar i SuSE 9.0 vid uppstart.
3. ImageMagick kan inte användas på FreeBSD 4-stable.
4. Vid användandet av KPart-objekt hos LabPlot kan storleken på fönstret inte ändras.

1. pstoedit arbetar inte korrekt ibland.
pstoedit has sometimes problems when converting postscript files created by Qt?. Especially
with truetype fonts Qt? seems to create corrupted postscript files. These postscript files may
look good when using ghostscript but fail when converting them with pstoedit.

I haven't found a solution for this problem and finally changed the standard fonts of LabPlot
to use fonts that produces no problems with pstoedit. I hope this get fixed in a future release
of Qt?.

2. LabPlot kraschar i SuSE 9.0 vid uppstart.
The original Qt? package of SuSE 9.0 has a bug when rotating text. So all applications using
this library to rotate text are crashing. SuSE provides an updated Qt? package for SuSE 9.0
on their website. So please update the Qt? package.

Unfortunately the text rotation of Qt? on SuSE 9.0 still has a bug so that the single letters of
a string are not rotated. To fix this you should update to SuSE 9.1 on which Qt? text rotation
works perfectly.

3. ImageMagick kan inte användas på FreeBSD 4-stable.
Vid kompilering av LabPlot på FreeBSD 4-stable tillsammans med ImageMagick verkar det
vara ett problem som endast finns på FreeBSD 4 :

/usr/include/sys/cdefs.h:273: warning: `_POSIX_C_SOURCE' is not defined

Jag har inge aning var problemet finns. Om någon kan åtgärda detta så tala om det för mig.
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F. N. gäller att inaktivera ImageMagick (--disable-ImageMagick) vid kompilering.
4. Vid användandet av KPart-objekt hos LabPlot kan storleken på fönstret inte ändras.

Vid fönsterstorleksändring till önskad storlek ladda om sidan med KPart. Det bör åtgärda
detta fel.

Chapter 11. Frågor och svar

11.1. For which platforms is LabPlot available?
11.2. Efter kompilering och start av LabPlot ser jag bara "Arkiv"- och "Hjälp"-menyerna. Verktygsraderna är
helt tomma. Vad är felet?
11.3. Hur exporterar jag det aktiva arbetsbladet som en bild?
11.4. Några analysfunktioner fungerar inte. Vad kan jag göra?
11.5. How do i use greek letters for title, axes label, etc.?
11.6. Hur använder jag LabPlot's objekt, diagram m. m. i min egen tillämpning?
11.7. Jag saknar en viktig egenskap. Vad kan jag göra?
11.8. Jag vill hjälpa till. Hur kan jag bidraga till LabPlot?

11.1. For which platforms is LabPlot available?
LabPlot is developed for Unix platforms and uses the Qt? toolkit and KDE. Normally you can expect
LabPlot to build and run on every platform KDE (>=3) supports. A recent list of supported platforms
and tips for compiling and running LabPlot can be found on  http://labplot.sf.net/wiki?Download.

I personally have access and can support the following platforms :

SuSE 10.0 (main development platform)• 
SuSE 9.3• 
SuSE 9.1• 
Fedora Core 4• 
Fedora Core 3• 
RedHat 9• 
Mandriva 2006• 
Mandrake 10.1• 
Mandrake 10.0• 
Slackware 10• 

With the help from some volunteers the following platforms are also known to work :

Debian 3.0• 
FreeBSD 4,5• 
PLD 2.0• 
CentOS 4• 

If you like to test and compile LabPlot on any other platform (like Solaris, Xantos, Windows, etc.),
please let me know. If you encounter any problem during compilation i may be able to help.

11.2. Efter kompilering och start av LabPlot ser jag bara "Arkiv"- och "Hjälp"-menyerna. Verktygsraderna är
helt tomma. Vad är felet?
LabPlot uses the standard way for creating the graphical user interface (GUI) of KDE applications. The
GUI of LabPlot is described in the file "LabPlotui.rc" which needs to be installed in the correct KDE
path so that KDE can build the menu, the toolbars, etc. On normal KDE installation "./configure
--prefix=$KDEDIR ; make ; make install" should put all files in the correct directories. (e.g.
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$KDEDIR/share/apps/LabPlot/ for "LabPlotui.rc"). Please have a look at your distribution on where to
install the needed files.

It is also possible to use a user defined directory for shared files used by KDE. This extra directories
can be specified in the environment variable KDEDIRS. So when installing LabPlot under /usr/local
you just need to add "/usr/local" to the KDEDIRS environment variable before starting KDE.

11.3. Hur exporterar jag det aktiva arbetsbladet som en bild?
There are three ways to export the active worksheet as image. The standard way is to use "File->Export
To Image". All Qt? supported image formats are allowed. Just select the desired format and the active
worksheet is exported. The second way to export as an image is to use "File->Export via pstoedit".
Here the active worksheet is exported to Postscript and then internally converted to the selected format
via pstoedit. A lot of non-image formats (like PDF or DXF) is supported too. You can select the image
size, scale and rotation in this dialog. The third way to export to an image is to use "File->Export via
ImageMagick". LabPlot uses the ImageMagick library to convert to all possible image formats (over
200 image formats are supported by ImageMagick). Like in "Export via pstoedit" you can select size,
scale and rotation of the image.

11.4. Några analysfunktioner fungerar inte. Vad kan jag göra?
LabPlot använder 'GNU Scientific Library' (gsl) för regression, histogram, fouriertransform och
icke-linjär anpasssning. Du kan använda LabPlot även om du inte har gsl installerat, men du kommer
inte att kunna använda de ovan nämda funktionerna. Så, installera gsl om du vill använda dem.

11.5. How do i use greek letters for title, axes label, etc.?
LabPlot uses the font "greek times" which was available on SuSE until version 9.0. You just have to
install the package xfntgreek-1.0-560.noarch.rpm to make this font available. If everything works you
should be able to see the greek letters (lower and upper case) in the Label Dialog and you can use them
for the label.

11.6. Hur använder jag LabPlot's objekt, diagram m. m. i min egen tillämpning?
Since the 1.2.3 release of LabPlot all classes of LabPlot are collected in the library libLabPlot. At the
moment you should have a look at the source packages for the documentation of all classes. After
testing how the library can be used i will improve the documentation application programming
interface (API) for the library by using doxygen. Please mail me if you have any questions.
Additionally I created a KPart object for LabPlot projects so you can display and edit a LabPlot *.lpl
file in your application. Please have a look at the KDE documentation on how to use KDE KParts
objects.

11.7. Jag saknar en viktig egenskap. Vad kan jag göra?
Titta i TODO-filen i LabPlot's dokumentation. Här är alla planerade egenskaper uppställda i mer eller
mindre sorterad ordning i vilken jag kommer att implementera dem i framtida utgåvor. Om du skulle
vilja ha med ytterligare egenskaper eller en listad egenskap tidigare, så e-posta mig och om möjligt
sänd exempeldata eller en kort beskrivning av vad du vill göra. Det är inte helt osannolikt att din
egenskap kommer att dyka upp i nästa stabila utgåve av LabPlot:-)

11.8. Jag vill hjälpa till. Hur kan jag bidraga till LabPlot?
Naturligtvis. Det finns mycket att göra. Även om du inte vet så mycket om programmering behövs
alltid krafter att leta efter felaktigheter, prova saker och komma med förslag. Även översättning och
dokumentation innebär alltid en massa arbete. Bara e-posta till mig om du behöver hjälp.

Chapter 12. License
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Program copyright 2006 Stefan Gerlach <gerlach@mbi-berlin.de>

Remember : LabPlot is still under development. There is a long list of missing features that will be
implemented in later versions of LabPlot.

Då det finns mycket att göra, behöver jag all den hjälp jag kan få. Vilket bidrag som helst såsom önskningar,
rättelser, felarapporter eller skärmdumpar är välkomna.

Documentation copyright 2006 Stefan Gerlach <gerlach@mbi-berlin.de>

This documentation is licensed under the terms of the GNU Free Documentation License.

This program is licensed under the terms of the GNU General Public License.

Appendix A. Installation
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Hur få tag på LabPlot

LabPlot can be found on its homepage at sourceforge.net : http://labplot.sf.net. There is an overview about all
available packages at http://labplot.sf.net/wiki?Download.

Krav

In order to successfully use LabPlot, you need at least a standard KDE 3.0 installation.

Följande bibliotek ingår i LabPlot-distributionen :

Cephes Math Library Release 2.3: June, 1995 : anpassad från Grace till att användas vid kraftfulla
matematiska funktioner (satskontroll) [Free]

• 

qwtplot3d 0.2.4beta : ordnar OpenGL 3D diagram. Används i QWT 3D plot.• 
qtiffio library : stöd för tiff-bildformat• 
audiofile 0.2.5 : stöd vid läsning/skrivning av ljudfiler [LGPL]• 
netcdf 3.5.0 : stöd för läsning/skrivning av filer med 'Unidata Network Common Data Form'
(netCDF) [se netcdf/COPYRIGHT]

• 

libundo 0.8.2 : support for Undo/Redo (not used at the moment)• 

Optional LabPlot uses following programs/libraries when available :

GNU scientific library (GSL) : används för specialfunktioner i satskontrollen och för de flesta
analysfunktionerna.

• 

Fastest Fourier Transform in the West (fftw or fftw3) : används för fouriertransform.• 
pstoedit : För exportering till *.eps,*.dxf,*.fig, m. m. via pstoedit måste pstoedit vara installerat.• 
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Imagemagick/ImageMagick-C++ : För exportering till mer än 100 bildformat måste ImageMagick++
vara installerat.

• 

Qt? Script for Applications : used for scripting and plugins for LabPlot.• 
JasPer library : stöd för JPEG 2000-bildformat.• 
cdf : stöd för läsning/skrivning av filer med 'Common Data Form (CDF)'.• 

Kompilering och installation

För att kompilera och installera LabPlot på ditt system skriv följande i huvudmappen på din
LabPlot-distribution:

% ./configure
% make
% make install

Since LabPlot uses autoconf and automake you should have not trouble compiling it. For many systems RPM
or DEB packages are available. Please check out the download section of the LabPlot homepage for all
supported platforms. Should you run into problems please report them to the author of LabPlot.
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